Opened 13 years ago

Last modified 20 months ago

#605 assigned bug

[VLC] resizing control window doesn't resize the timeview

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Normally, under BeOS you could resize vlc to show expanded version of time view. Under Haiku you could do it too, but only once.

This might help show this problem better, note the black area won't expand back out after shrinking it down one time.

Attachments (1)

vlc-screenshot.png (14.4 KB) - added by scottmc 11 years ago.
This might help show this problem better, note the black area won't expand back out after shrinking it down one time.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 13 years ago by axeld

Can't reproduce this. Can you elaborate a bit more what you mean by "only once"?

comment:2 Changed 13 years ago by axeld

Ah, don't mind, I see what you mean :-) When the VLC control window is maximized, the timeview gets larger and takes more space - but only the first time you enlarge that window.

comment:3 Changed 11 years ago by aldeck

Platform: All

If i understand the problem as "resizing vlc control window didn't resize the timeview" , then it works great here under vmware with hrev21836, vlc-0.8.6c-BeOS

comment:4 Changed 11 years ago by diver

Component: - GeneralKits/Interface Kit

I just checked and it still not working.

Changed 11 years ago by scottmc

Attachment: vlc-screenshot.png added

This might help show this problem better, note the black area won't expand back out after shrinking it down one time.

comment:5 Changed 10 years ago by richienyhus

After resizing 2 times, time view still does not resize in hrev28339 pre-alpha.

comment:6 Changed 10 years ago by diver

Summary: [VLC] resizing main window doesn't work second time[VLC] resizing control window didn't resize the timeview

comment:7 Changed 10 years ago by diver

Summary: [VLC] resizing control window didn't resize the timeview[VLC] resizing control window doesn't resize the timeview

comment:8 Changed 9 years ago by diver

Version: R1 development

Still here in hrev32617.

comment:9 Changed 9 years ago by diver

Still here in hrev35569.

comment:10 Changed 9 years ago by diver

Version: R1/pre-alpha1R1/Development

comment:11 Changed 8 years ago by diver

Still reproducible in hrev38300.

comment:12 Changed 5 years ago by waddlesplash

VLC no longer even works, as it was linked against a different libz.

Close?

comment:13 Changed 4 years ago by waddlesplash

Resolution: invalid
Status: newclosed

No response. Closing.

comment:14 Changed 4 years ago by diver

Description: modified (diff)
Resolution: invalid
Status: closedreopened

This is still an issue.

comment:15 Changed 4 years ago by miqlas

I'm almost sure, that I had this problem with the 0.8.6 (the latest with native GUI) version on BeOS R5.0.3 / Zeta.

If i remember correctly, the 0.5.x - 0.7.x rev VLC had nice GUI features, but in later revisions many of this features was disabled because they was broken, and nobody fixed them. I remember, because i talked about it with my friends.

Please, check first in BeOS. (If you did that, then sorry for noise.)

Last edited 4 years ago by miqlas (previous) (diff)

comment:16 Changed 4 years ago by pulkomandy

@waddlesplash: there is a working version at http://haiku.uwolke.ru/repo/binaries-x86_gcc2/#En . It is also easy to workaround the libz problem with some symlinks to run the version from haikuware (and besides these UI issues it works quite well).

comment:17 Changed 4 years ago by diver

Description: modified (diff)

I've just tested again in BeOS and it works correctly there.

comment:18 Changed 20 months ago by axeld

Owner: changed from axeld to nobody
Status: reopenedassigned
Note: See TracTickets for help on using tickets.