Opened 9 years ago

Closed 9 years ago

#6130 closed bug (fixed)

ATAPI drive not always working with r36986 and later

Reported by: Ziusudra Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: Cc: axeld, mdisreali@…
Blocked By: Blocking: #3025, #3473
Has a Patch: no Platform: All

Description

hrev36986 introduces a bug that prevents my ATAPI drives from working when booted without a disc in the drive.

When booting without a disc everything seems fine in syslog but putting in a disc gets no response.

Attachments (3)

r36986-syslog.txt (182.4 KB ) - added by Ziusudra 9 years ago.
r37010-no-disc-syslog.txt (86.4 KB ) - added by Ziusudra 9 years ago.
booting without disc in drive
r37010-with-disc-syslog.txt (111.5 KB ) - added by Ziusudra 9 years ago.
booting with disc in drive

Download all attachments as: .zip

Change History (13)

by Ziusudra, 9 years ago

Attachment: r36986-syslog.txt added

comment:1 by Ziusudra, 9 years ago

I'll put this here, let me know if you want another ticket.

hrev36989 (with or without hrev36990) adds a new bug.

(After booting with a disc in the drive.) Putting in a certain Enhanced CD causes the kernel to spam syslog with:

KERN: atapi 2-0 error: device indicates transfer error after dma
KERN: check_sense: Medium error

This repeats until I eject the disc at which point the kernel reports that the media was changed (not removed), tries to scan the disc and then reports the media was removed. Then putting in a plain audio CD results in:

KERN: ata 2 error: command failed, error bit is set. status 0x51, error 0x54
KERN: atapi 2-0 error: device indicates transfer error after dma
KERN: check_sense: Illegal request

being printed to syslog 37 times before successfully reading the disc.

The other enhanced CD I have does not do this.

comment:2 by axeld, 9 years ago

Can you retest with hrev37006 or later? I've enabled debug output which should give a better idea of what happens.

In general, though, it's normal that some CDs now produce error messages when you put them into the drive. The CD should always work, though, anyway.

comment:3 by axeld, 9 years ago

Just noticed that what I wrote is a bit ambiguous: those error messages should stop at some point, it should only happen 19 times at most (though maybe it's issued twice per command).

by Ziusudra, 9 years ago

Attachment: r37010-no-disc-syslog.txt added

booting without disc in drive

by Ziusudra, 9 years ago

Attachment: r37010-with-disc-syslog.txt added

booting with disc in drive

comment:4 by Ziusudra, 9 years ago

After booting without a disc in the drive I put in a normal audio CD and there was no output to syslog.

After booting with that CD in the drive I put in the enhanced CD and as the syslog shows it did eventually read the CD after about 10-15 minutes.

For the audio CD, it puts out 1 Illegal request per loop and by my count went through the loop 37 times. Oddly enough this happens almost instantly. Three other audio CDs have the same result.

For the Enhanced CD, it puts out 4 Medium errors per loop and by my count also went through the loop 37 times.

The other Enhanced CD only goes through the loop once without error. As do the Gobe Productive, R5, R4.5, R4 and Corum CDs.

At no time have I seen the adjusted capacity message.

comment:5 by Disreali, 9 years ago

Cc: mdisreali@… added

comment:6 by bga, 9 years ago

Just to mention that I am seeing exactly the same problem in recent revisions. Inserting a CD after boot results in nothing happening (I did not wait for 15 minutes tough). Syslog does not show anything when a CD is inserted after boot either.

Also, if I am not mistaken, even without a CD in the drive, DriveSetup would show the CD drive entry. It is not showing anything (as if the CD drive was not present).

If I boot with a CD in the drive, it shows up i DriveSetup but I get millions of errors and end up with problems when reading standard data CDs that used to work without problems.

comment:7 by axeld, 9 years ago

Blocking: 6668 added

comment:8 by axeld, 9 years ago

Blocking: 6335 added

(In #6335) I assume this is a duplicate of #6130, too.

comment:7 by axeld, 9 years ago

Blocking: 6335, 6668 removed
Owner: changed from marcusoverhagen to axeld
Status: newin-progress

comment:8 by axeld, 9 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev38828, sorry for the long delay; I pretty much forgot about it until I ran into it a few days back.

Note: See TracTickets for help on using tickets.