Opened 13 years ago

Closed 12 years ago

#615 closed bug (fixed)

[BMenu] has some issues

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: boolaiku@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

1 Open Find window in Tracker and press "All files and folders" menu, while it selected click on BTextControl - menu should close, but it won't. 2 Repeat step 1 but click on BPanel and then click that menu again, menu should open (selected) but it doesn't happen. Another example: open Find window, click on desktop and then try to activate "All files and folders" menu, you will need for this 3 (three) clicks, and 2 under Be. 3 While menu is opened Esc should close it as in BeOS. 4 On menu activation blue border around BTextControl should disappear.

Attachments (1)

stickyMiniMenu.diff (400 bytes) - added by boolaiku@… 13 years ago.
MiniMenuField didn't tell the popumenu to be sticky

Download all attachments as: .zip

Change History (26)

comment:1 Changed 13 years ago by diver

Cc: stefano.ceccherini@… added

comment:2 Changed 13 years ago by diver

Adding Stefano, as he is our Menu thing guru :-)

comment:3 Changed 13 years ago by diver

*5. Just found another bug, also in Find window - there is an arrow with saved querys, if you click there menu will open and rapidly close, while in BeOS this doesn't happen.

comment:4 Changed 13 years ago by diver

Summary: [BMenu] have some issues[BMenu] has some issues

comment:5 Changed 13 years ago by axeld

Owner: changed from axeld to jackburton

comment:6 Changed 13 years ago by jackburton

Status: newassigned

comment:7 Changed 13 years ago by jackburton

1 and 2 might as well be the same thing as #594. It seems the menu doesnt' catch the click if it's too short (if you don't keep the button down for some time).

  1. Keyboard navigation isn't yet there.
  2. Indeed. It's somewhat related to 3, meaning menus should have focus to be

able to be navigated via keyboard.

comment:8 Changed 13 years ago by jackburton

1, 3, and 4 should be fixed.

comment:9 Changed 13 years ago by diver

(In reply to comment #3)

1 and 2 might as well be the same thing as #594. It seems the menu doesnt' catch the click if it's too short (if you don't keep the button down for some

time).

It seems that 1 and 2 urelated to 594, as it already fixed.

comment:10 Changed 13 years ago by jackburton

In short, only problem 5 is still showing up, right ?

comment:11 Changed 13 years ago by diver

(In reply to comment #6)

In short, only problem 5 is still showing up, right ?

1, 2 and 5 are not yet fixed.

comment:12 Changed 13 years ago by jackburton

I can't reproduce 1 anymore. I'm testing revision 17682. But you're right: #2 is still showing up. So, #2 and 5 are still alive.

comment:13 Changed 13 years ago by jackburton

problem 2 should be gone with hrev18067

comment:14 Changed 13 years ago by diver

(In reply to comment #9)

problem 2 should be gone with hrev18067

It still here in hrev18071. So only 2 and 5 is still showing up.

comment:15 Changed 13 years ago by boolaiku@…

Cc: boolaiku@… added

comment:16 Changed 13 years ago by jackburton

Since in beos hrev5 that menu is sticky (IIRC), there's something wrong in our implementation of BPopUpMenu.

comment:17 Changed 13 years ago by boolaiku@…

(In reply to comment #12)

Since in beos hrev5 that menu is sticky (IIRC), there's something wrong in our implementation of BPopUpMenu.

[about problem 5] I'm sorry but concerning this use case, the BPopUpMenu is conforming to the doc... I can't see why i should behave otherwise (also in #636). The implementation seems correct to me. Am i missing something? :/

Again, sorry to insist on this (especially if 'im wrong hehe:) )

Changed 13 years ago by boolaiku@…

Attachment: stickyMiniMenu.diff added

MiniMenuField didn't tell the popumenu to be sticky

comment:18 Changed 13 years ago by jackburton

problem 2 was finally fixed by Axel in hrev18483, and was caused by #727.

comment:19 Changed 13 years ago by boolaiku@…

(In reply to comment #14)

problem 2 was finally fixed by Axel in hrev18483, and was caused by #727.

Testing on hrev18501, and problem 2 is still there, but the behaviour changed a bit it seems. I'm testing on real hardware and on qemu.

Here are the sequences causing the problem (which is: menu opens then closes immediately, sometimes it's not visible):

Legend:

o = click out of the window v = click on the view m = click on the menu

With short and long indications possible.

1) v, mshort : ok 2) v, mlong : problem appears once on two if you repeat this sequence 3) o, m, mshort : ok 4) o, m, mlong : same as 2) 5) o, v, mshort : ok 6) o, v, mlong : same as 2)

In addition, sometimes, the menu doesn't close itself when clickin out of the window, but i can't reproduce that reliably.

comment:20 Changed 13 years ago by jackburton

(In reply to comment #15)

(In reply to comment #14)

problem 2 was finally fixed by Axel in hrev18483, and was caused by #727.

Testing on hrev18501, and problem 2 is still there, but the behaviour changed a bit it seems. I'm testing on real hardware and on qemu.

Axel's change in hrev18597 should've fixed this (or at least, I can't reproduce it following the steps you wrote :) ). Can you confirm ?

comment:21 in reply to:  20 Changed 13 years ago by boola

Platform: All

Replying to jackburton:

Axel's change in hrev18597 should've fixed this (or at least, I can't reproduce it following the steps you wrote :) ). Can you confirm ?

Testing on hrev18626, and it's still there... All drop-down menus show this behavior, i verified it in the Find applet and Chart.

comment:22 Changed 12 years ago by jackburton

Description: modified (diff)
Summary: [BMenu] has some issuesESC key doesn't close menu

Renamed bug because all other bugs have been fixed in hrev19827

comment:23 Changed 12 years ago by axeld

While it's never a good idea to put more than one bug in one report, I also don't think it's good to just remove their description, as that makes it almost useless for previous bug fixes. For reference, I paste the original description below:

  1. Open Find window in Tracker and press "All files and folders" menu, while it selected click on BTextControl - menu should close, but it won't.
  2. Repeat step 1 but click on BPanel and then click that menu again, menu should open (selected) but it doesn't happen.
    Another example: open Find window, click on desktop and then try to activate "All files and folders" menu, you will need for this 3 (three) clicks, and 2 under Be.
  3. While menu is opened Esc should close it as in BeOS.
  4. On menu activation blue border around BTextControl should disappear.

comment:24 Changed 12 years ago by jackburton

You are right, of course. I should've closed this bug and opened a new one. Sorry. Next time.

comment:25 Changed 12 years ago by jackburton

Description: modified (diff)
Resolution: fixed
Status: assignedclosed
Summary: ESC key doesn't close menu[BMenu] has some issues

Reverted to original description

Note: See TracTickets for help on using tickets.