Opened 8 years ago

Closed 11 days ago

Last modified 11 days ago

#6153 closed bug (invalid)

PANIC: Unable to find a bootable partition, Error Bit Is Set ATA error

Reported by: Zwolfe Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/alpha2
Keywords: PANIC, KDL, Error Bit Is Set, ATA, bootable partition Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Progress goes as far as getting to where the Live CD of Alpha 2 checks for hard disks.

It throws an "ATA 0/1 Error Bit Is Set" error when locating the HDD's, which there are two of. ATA 0, ATA 1 which I see in KDL.

KDL message: "PANIC: Unable to find bootable partition" or a message very similar.

Status: 0x51 Error: 0x54

I have a blank partition for installation of Haiku, where Alpha 1 formerly resided.

ALPHA 1 LOADS FINE! Alpha 2, not so much. My disc of Alpha 2 loads perfectly on another PC, it isn't the media.

I disabled DMA, USB in the BIOS and that did not help. I have forced PIO 4 mode in BIOS for the HDD's, that didn't help either.

I have toggled / enabled every safe mode setting of Haiku and nothing works. I spent a whole night trying to get it working.

Hardware: Shuttle Socket-A AMD motherboard, nForce 2 Ultra 400 chipset, old Athlon XP CPU. ATA/100 HDD transfer, not SATA. This is hardware from 2002/2003. A Western Digital 120GB drive and a Maxtor 80GB drive I believe.

Change History (6)

comment:1 Changed 8 years ago by Coldfirex

Able to retest with a recent nightly build?

comment:2 Changed 7 years ago by scottmc

Can you recheck this with a recent Haiku build?

comment:3 Changed 7 years ago by scottmc

Blocking: 7665 added

comment:4 Changed 6 years ago by diver

Component: - GeneralDrivers/Disk
Owner: changed from nobody to marcusoverhagen

comment:5 Changed 11 days ago by waddlesplash

Resolution: invalid
Status: newclosed

comment:6 Changed 11 days ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.