Opened 9 years ago

Closed 9 years ago

#6169 closed bug (fixed)

Webpositive occasionally segfaults when closing tab

Reported by: Ziusudra Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

521 on 36872

Note that the thread that faults is the tab that gets switched to after the current tab is closed.

Attachments (1)

Webpositive-521-close-tab-gdb.txt (1.0 KB ) - added by Ziusudra 9 years ago.
gdb backtrace

Download all attachments as: .zip

Change History (8)

by Ziusudra, 9 years ago

gdb backtrace

comment:1 by stippi, 9 years ago

The favicon is sent asynchronously, the window only requests it from another thread. One situation I can imagine is that the favicon is sent after the corresponding BWebView has already been destroyed. Could it be that it happens when the tab you have closed was still loading or possibly just finished loading?

comment:2 by stippi, 9 years ago

The issue should hopefully be fixed in hrev522, at least what I fixed could definitely lead to this crash. This revision is not available as a package yet, in any case, but maybe you are building Web+ yourself and can put it to a test.

comment:3 by Ziusudra, 9 years ago

Could it be that it happens when the tab you have closed was still loading or possibly just finished loading?

Yes, in fact, it happens when trying to get to http://mmlr.dyndns.org/timeline. I hadn't noticed before that after the failure to connect message is displayed, there is still a half full progress bar. Closing the tab while the progress bar is there will fault, but waiting until it goes away will not. Also, closing the tab before the error message is displayed will not.

comment:4 by stippi, 9 years ago

So, have you been able to try with the trunk revision, or will that have to wait until I make a new package available?

comment:5 by Ziusudra, 9 years ago

I have not had time to trying building. Haven't actually succeeded in building before but haven't tried since about a hundred revisions ago. And I'm having issues with the BFS partition that the Web+ trunk is checked out to.

So, yeah, it'll probably have to wait until a new package is available.

comment:6 by Ziusudra, 9 years ago

Unable to reproduce on 526 built by vooshy.

Please close as fixed.

Thanks stippi, for this and everything else.

comment:7 by stippi, 9 years ago

Resolution: fixed
Status: newclosed

No problem, thanks for confirmation! Now I just need to prepare a new package...

Note: See TracTickets for help on using tickets.