Opened 9 years ago

Closed 8 years ago

#6171 closed bug (fixed)

WebPositive cannot show Chinese/Japanese/Korean fonts

Reported by: dsobodash Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/alpha2
Keywords: chinese, unicode, webkit, cjk, text, rendering Cc:
Blocked By: #6000 Blocking:
Has a Patch: no Platform: x86

Description

I am pretty sure this is a webkit problem, but the IRC channel advised me to post here.

After installing the Vera Sans YuanTi family as well as the AR PL ShanHeiSun Uni fonts from Linux, I am unable to view Chinese in WebPositive. I have tested both the Alpha 2 release and the hrev37098 nightly.

When viewing pages such as Google in Chinese (http://www.google.com.hk, clear your cookies) all text is displayed as empty boxes. Web pages like Baidu (http://www.baidu.com/) do not even load.

I believe this is a webkit problem because I have seen the same behavior on Debian when it is installed in Chinese if I use the webkit test, Midori or the webkit fork of gnome's Epiphany browser to view Chinese web pages.

In fact, I have never seen any webkit browsers other than Chrome and Safari successfully display CJK type.

I tried setting the Haiku system and WebPositive default fonts to ones with Chinese unicode. This allows Tracker to display Chinese filenames and also allows Chinese support in BeZilla. For WebPositive, this fix is a negative. :(

Would be nice to get this fixed by the time Haiku goes beta.

Change History (8)

comment:1 by stippi, 9 years ago

I am not sure if the Haiku WebKit port handles the encoding setting of the respective web pages correctly. If you can somehow test it, it would be cool if you could check what happens when you have a page that containes Chinese characters, but encoded in UTF-8. I think this should actually work then.

comment:2 by stippi, 9 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #6000.

in reply to:  2 comment:3 by dsobodash, 9 years ago

Resolution: duplicate
Status: closedreopened

Replying to stippi:

Duplicate of #6000.

Is this really a duplicate? His post talks about a failure to render the pages at all (which I saw in Baidu) while mine talks about a failure to actually render the text.

If you had checked, Google in Chinese is sending its text in UTF-8. It is rendering as empty boxes, not garbage. The empty boxes show it is processing the UTF-8 but not finding matching glyphs. This is strange, because I configured WebPositive to use the same Chinese fonts that work in Tracker and BeZilla.

That is why I believe this is a webkit error and not a WebPositive error: it is the same issue I have seen in Midori and Epiphany.

comment:4 by luroh, 9 years ago

Blocked By: 6000 added

(In #6000) Rev 37719, Web+ 535.

WebPositive no longer display blank pages (fixed somewhere in the 37496-37529 range), although not all Chinese glyphs are displayed properly by default.

Closing this ticket, the remaining font issues are handled in #6171.

comment:5 by stippi, 9 years ago

At the moment, WebPositive displays all the Chinese glyphs on the pages you mention. The only remaining bug would be if you configure a different Chinese font and it is not used. Can you make some tests with that? If you configure your fonts (can those be freely downloaded?), are they being used or does it use the same fallback-font as before (VL Gothic)?

comment:6 by citi324, 9 years ago

VL Gothic is a Japanese font. It can display some - but not all - characters used in the Chinese language. To display Chinese language properly, Haiku needs a real Chinese font. WenQuanYi used in Ubuntu and other Linux distros is a good choice.

http://sourceforge.net/projects/wqy/

comment:7 by stimut, 9 years ago

As already mentioned, the original problem is now fixed and the issue has changed to a font fallback problem (assuming there is one). Font fallback is being dealt with in #6118 and posibly #6967 (I'm not sure of WebPositive's internals so I'm not sure if it's also relevant).

As such, I think this ticket can be closed.

comment:8 by scottmc, 8 years ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.