Opened 9 years ago

Closed 3 years ago

#6182 closed bug (fixed)

Strange owner and group in Terminal

Reported by: oxoocoffee Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha2
Keywords: chgrp chown Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I am running GCC 4 Hybrid R37017. Not sure if this is BFS file system problem or chown chgrp util. After downloading groff tar.gz I try to uncompress it with tar -zxvf groff-1.22.1.tar.gz onto /User/Projects (second BFS partition). After uncompressing I see that running ls -l shows

drwxr-xr-x 1 1000 users 4096 Jan 9 groff-1.22.1

Now running chgrp -R root groff-1.22.1 and than chown -R user groff-1.22.1 changes it to

drwxr-xr-x 1 user 4294267295 4096 Jan 9 groff-1.22.1

now running again chgrp -R root make it as

drwxr-xr-x 1 4294267295 root 4096 Jan 9 groff-1.22.1

back and forth.

Change History (2)

comment:1 by oxoocoffee, 9 years ago

One thing. It does changes all files and sub folders to 4294267295 in groff-1.22.1

comment:2 by axeld, 3 years ago

Component: File Systems/BFSSystem/Kernel
Resolution: fixed
Status: newclosed

I've downloaded groff-1.22.1 from http://ftp.gnu.org/gnu/groff/groff-1.22.1.tar.gz, but I could not reproduce the issue. I'll assume it has been fixed in the mean time.

Note: See TracTickets for help on using tickets.