Opened 9 years ago

Closed 5 years ago

#6185 closed bug (fixed)

System hang when using font with negative size value

Reported by: X512 Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If font with negative size used, system hang. Work only cursor(but slow) and KDL calling. Mayble need check font size value in app_server.

Attachments (1)

fontHang.cpp (1.2 KB) - added by X512 9 years ago.
System hanging code

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by X512

Attachment: fontHang.cpp added

System hanging code

comment:1 Changed 9 years ago by Coldfirex

How did you change the font to a negative number? I opened the Fonts preference and it only allows a drop down box selection.

comment:2 Changed 9 years ago by X512

No. I set negative font size of BFont object. See attached program.

comment:3 Changed 8 years ago by leavengood

I compiled and tested this on a GCC4 compiled alpha3 RC Haiku at hrev41768 and I did not see the lockup. Could you test again X512, since it has been a year?

comment:4 Changed 8 years ago by scottmc

Works fine with GCC2 as well, on hrev41884.

The Be Developer's Guide c1997 says on page 432 that BFont SetSize() valid sizes range from less than 1.0 point through 10000 points. So perhaps we should add a range check to SetSize() to limit the valid inputs?

comment:5 in reply to:  3 Changed 8 years ago by X512

Replying to leavengood:

I compiled and tested this on a GCC4 compiled alpha3 RC Haiku at hrev41768 and I did not see the lockup. Could you test again X512, since it has been a year?

I can't reproduce bug in hrev43243. But it can be unhandled behavior and arguments check needed in app_server.

comment:6 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Not reproductible anymore.

Note: See TracTickets for help on using tickets.