Opened 9 years ago

Closed 8 years ago

#6225 closed bug (duplicate)

WebPositive Ctrl+plus (Increase Size) Key Combination Does Not Work

Reported by: jscipione Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #2499 Blocking:
Has a Patch: no Platform: All

Description

Noticed bug in SVN Rev 515 of WebPositive

The key combination ctrl+plus_sign key combination that is suppose to increase the size of the webpage is not working. The Ctrl+minus_sign (Decrease size) and Ctrl+0 (Default Size) key combinations are working. If you go to the View menu and select Increase size, that also does work, only the key combo doesn't work.

Steps to reproduce:

Open WebPositive

Press Ctrl+plus_sign

Notice that the size has not increased

Change History (5)

comment:1 by X512, 9 years ago

Haiku by default use Alt key as command key. Try to use Alt + and Alt -.

comment:2 by humdinger, 9 years ago

It works here with hrev526 (default CMD = ALT key, German keymap).

comment:3 by jscipione, 9 years ago

Tested with hrev526, still does not work (default CMD = alt key, US keymap). I am using an Apple Titanium keyboard. I am not pushing the wrong key. alt+minus_sign decreases size and alt+0 goes to default size. alt+plus_sign does nothing.

comment:4 by X512, 9 years ago

Blocked By: 2499 added

To make Alt + work need press + key on numpad. Hotkeys handling implemented in libbe or app_server, not in WebPositive. Same problem with keymaps with non-english set. This problem is duplicate of #2499.

comment:5 by jscipione, 8 years ago

Resolution: duplicate
Status: newclosed

duplicate of #2499, this issue is not limited to just WebPositive, Alt+plus doesn't work in any app with default keymap.

Note: See TracTickets for help on using tickets.