Opened 9 years ago

Closed 7 years ago

#6233 closed bug (fixed)

Deskbar no longer able to show 24-hour clock

Reported by: Disreali Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Preferences/Time & Date Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In hrev37243, the 24-hour clock setting was removed from Deskbar preferences in favor of the Locale Kit's preflet, yet the Locale 24-hour clock setting does nothing. Deskbar shows a 12-hour even when set to 24-hour.

Attachments (1)

Deskbar_crash_r37243.txt (4.7 KB ) - added by Disreali 9 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by pulkomandy, 9 years ago

Status: newassigned

The settings in locale preflet are not perfectly finished, yet. It will work, however, if you select a language that shows a 24-hour clock in the country tab (try French (France)) for example. The only problem is that the change isn't immediate, you may have to restart the computer, because the preflet won't notice the locale kit when it changes the settings. I'll have a look to fix both issues.

Do you need to force 24-hour clock while it's not the default setting for your country ?

comment:2 by Disreali, 9 years ago

I just experienced Deskbar crash and it looks like liblocale's date format is the culprit. Attaching bt.

by Disreali, 9 years ago

Attachment: Deskbar_crash_r37243.txt added

comment:3 by pulkomandy, 9 years ago

Mh... This deskbar crash is strange, since ICU is not calling BChannelControl anywhere. Moreover, it's not related to this ticket.

comment:4 by taos, 9 years ago

As intended, I can switch from 12 to 24-hour clock in hrev37573 by changing the country settings in locale preferences. After a restart I'm indeed greeted by the 24-hour clock. But there's something strange: whenever I open the country settings (German (Germany) in my case), the clock options (not the clock itself) are reset to 12-hour.

BTW, are there any plans to use the locale preferences to change the tracker clock and date preferences automatically?

comment:5 by pulkomandy, 9 years ago

I noticed the bug of the setting resetting to 12-hour. That's why this ticket is not closed yet. And yes, tracker will be updated, too.

comment:6 by pulkomandy, 9 years ago

Resolution: fixed
Status: assignedclosed

comment:7 by jstressman, 7 years ago

Component: Preferences/LocalePreferences/Time & Date
Resolution: fixed
Status: closedreopened
Version: R1/alpha2R1/Development

I don't know who thought it was a good idea to remove the 24 hour clock option (which was removed in hrev37243), but this most definitely should be an option not tied to locale.

http://en.wikipedia.org/wiki/24-hour_clock

The 24-hour clock is a convention of time keeping in which the day runs from midnight to midnight and is divided into 24 hours, indicated by the hours passed since midnight, from 0 to 23. This system is the most commonly used time notation in the world today. It is the international standard notation of time (ISO 8601). In the practice of medicine, the 24-hour clock is generally used in documentation of care as it prevents any ambiguity as to when events occurred in a patient's medical history. It is popularly referred to as military time or astronomical time in the United States, Canada, and a handful of other countries where the 12-hour clock is still dominant.

It is not only the international standard, but it is widely used even in countries like the United States for military time, science, medicine, etc.

Note specifically this part: http://en.wikipedia.org/wiki/24-hour_clock#Military_time

In part it states "The 24-hour clock is commonly used there only in some specialist areas (military, aviation, navigation, tourism, meteorology, astronomy, computing, logistics, emergency services, hospitals), where the ambiguities of the 12-hour notation are deemed too inconvenient, cumbersome, or outright dangerous, with the military's use being the most famous example."

So while it isn't the general "standard" in places like the US, it is still very widely used in numerous fields where more unambiguous time keeping is required.

Asserting that people in the US can't use 24hr time without pretending they're in a different country was a mistake.

(All that is aside from it being odd to begin with that it was deemed a good idea to tell people in the US etc that they simply couldn't use 24hr notation even if they wanted to.)

This definitely needs to be put back in.

comment:8 by anevilyak, 7 years ago

I'm not at home right now to verify, but I'm quite certain you can tweak your locale settings to use 24h without changing to a different country. I'm using 24h at least and I have it set to US otherwise.

comment:9 by jstressman, 7 years ago

Ah, you're right. You can under locale.

Then let's update this to say that it doesn't make sense to not have a setting related to time under the time and date settings. It's fine to keep it under locale as well, but can anyone give me a good reason why the same setting shouldn't definitely be under the first place almost every user is going to look for it? Just like I did, and other people in the chat just now?

(Sorry, I missed taos' comment about being able to change it in locale preferences. I thought they just meant that they could change it by changing their locale, not a specific 12/24hr setting.)

in reply to:  9 comment:10 by anevilyak, 7 years ago

Resolution: fixed
Status: reopenedclosed

Replying to jstressman:

Then let's update this to say that it doesn't make sense to not have a setting related to time under the time and date settings. It's fine to keep it under locale as well, but can anyone give me a good reason why the same setting shouldn't definitely be under the first place almost every user is going to look for it? Just like I did, and other people in the chat just now?

Please file a new enhancement ticket for that rather than hijacking an existing, already fixed ticket.

Note: See TracTickets for help on using tickets.