Opened 9 years ago

Closed 8 years ago

#6263 closed bug (fixed)

Bash ls -Q

Reported by: lorglas Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: bash ls Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Hallo zusammen,

wenn der Befehl ls -Q verwendet wird, werden Dateinamen mit Umlauten nicht richtig angezeigt. Man erhält folgende Ausgabe "\303\266\303\266 --- \303\266\303\266"

Original Dateiname: öö --- öö

Bei ls -q bekommt man auch eine merkwürdige Ausgabe.

Gruß lorglas

Change History (7)

comment:1 Changed 9 years ago by humdinger

Hey lorglas, when I mentioned Trac being localized, I only meant the interface. There isn't a translation-AI yet... :)

I think your ticket would be easy enough to follow even in German though. Anyway:

  • create a file "ö --- ö"
  • ls works OK.
  • ls -Q

--> returns "\303\266\303\266 --- \303\266\303\266" instead.

  • ls -q

--> returns "?? --- ??" instead.

comment:2 Changed 9 years ago by lorglas

Hey Humdinger,

sorry my mistake, the next one is in english and thanks for translating.

comment:3 Changed 8 years ago by diver

Component: - GeneralApplications/Command Line Tools
Version: R1/alpha2R1/Development

Still present in hrev41908.

comment:4 Changed 8 years ago by leavengood

Owner: changed from nobody to leavengood
Status: newassigned

I didn't get a chance to test this in Haiku but I suspect it was fixed by my recent changes to add locale environment variables. Taking ownership so I can verify it was fixed.

comment:5 Changed 8 years ago by diver

Nope, it's still here in hrev42405.

comment:6 in reply to:  5 Changed 8 years ago by lorglas

Hello, i test it with the Alpha3 (witch we can download, not the daily Download) and the Problem is still present.

Replying to diver:

Nope, it's still here in hrev42405.

comment:7 Changed 8 years ago by zooey

Resolution: fixed
Status: assignedclosed

Fixed in hrev43310.

Note: See TracTickets for help on using tickets.