Opened 13 years ago

Closed 11 years ago

#630 closed bug (fixed)

[app_server] crash on cat /dev/random in terminal

Reported by: diver Owned by: axeld
Priority: critical Milestone: R1
Component: Servers/app_server Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by wkornewald)

app_server (i think) could crash if you type in Terminal /dev/random, while it print lots of thing try to play with selection. After several seconds screen goes white with only 1 string, screenshot will follow. This could be continue of #80 Tested with hrev17585 under vmware.

Attachments (3)

dev_random.PNG (4.2 KB) - added by diver 13 years ago.
screenshot
kdl.PNG (14.4 KB) - added by diver 13 years ago.
kdl
dev_random2.PNG (21.5 KB) - added by diver 13 years ago.
app_server crash

Download all attachments as: .zip

Change History (13)

comment:1 Changed 13 years ago by diver

This is what i get from serail port:

vm_soft_fault: va 0x31b not covered by area in address space vm_page_fault: vm_soft_fault returned error -2147478783 on fault at 0x31b, ip 0x 483eed, write 0, user 1, thread 0x5f vm_page_fault: sending team "/boot/beos/system/servers/app_s" 0x20 SIGSEGV, ip 0 x483eed ("libbe.so_seg0ro" +0x16feed) ps2: mouse_close input/mouse/ps2/0 ps2: ps2_dev_command cmd 0xf5, out 0, in 0, dev input/mouse/ps2/0 ps2: ps2_dev_command wait for ack res 0x00000000, wait-time 1 ps2: ps2_dev_command got ACK ps2: ps2_dev_command result 0x00000000 ps2: input/keyboard/at/0 not enabled, data 0xfa dropped

Changed 13 years ago by diver

Attachment: dev_random.PNG added

screenshot

comment:2 Changed 13 years ago by axeld

I cannot reproduce this (hrev17579). Can you provide more info (like what fonts are you using)? Also, gdb is now working again, so maybe you can attach a back trace?

Changed 13 years ago by diver

Attachment: kdl.PNG added

kdl

Changed 13 years ago by diver

Attachment: dev_random2.PNG added

app_server crash

comment:3 Changed 13 years ago by diver

Can you provide more info (like what fonts are you using)?

I use default fonts without any changes to terminal settings.

Also if you open Spy memory usage menu in process controller you could see that while cat /dev/random app_server will eat memory and it doesn't frees when you close terminal window. Mem leak?

comment:4 Changed 13 years ago by diver

blocked: 634

comment:5 Changed 13 years ago by wkornewald

Description: modified (diff)
Platform: All

comment:6 Changed 13 years ago by axeld

Component: GeneralUser Interface/app_server

comment:7 Changed 12 years ago by diver

Hmm, cat /dev/random doesn't work anymore, should i open another bug for this?

comment:8 in reply to:  7 Changed 12 years ago by kaliber

Replying to diver:

Hmm, cat /dev/random doesn't work anymore, should i open another bug for this?

Please look at bug #1366.

comment:9 Changed 12 years ago by diver

Ok, now it jus quits Terminal, but leaves it in team menu.

comment:10 Changed 11 years ago by jackburton

Resolution: fixed
Status: newclosed

This was obviously fixed in the meantime.

Note: See TracTickets for help on using tickets.