Opened 9 years ago

Closed 7 months ago

#6323 closed bug (invalid)

wifi drops after a few mins on my Acer Aspire One

Reported by: l8night Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/net_server Version: R1/alpha2
Keywords: Cc: modeenf
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

on my Acer Aspire One I find that the wifi works for a bit then just drops ifconfig then shows

~> ifconfig
/dev/net/atheroswifi/0
        Hardware Type: Ethernet, Address: 00:24:2b:1d:ae:cd
        inet addr: 169.254.0.113, Bcast: 169.254.255.255, Mask: 255.255.0.0
        MTU: 1500, Metric: 0, up broadcast link auto-configured
        Receive: 1587 packets, 0 errors, 1376409 bytes, 0 mcasts, 0 dropped
        Transmit: 1629 packets, 1 errors, 195121 bytes, 0 mcasts, 0 dropped
        Collisions: 0

/dev/net/rtl81xx/0
        Hardware Type: Ethernet, Address: 00:23:8b:54:d7:04
        inet addr: 169.254.0.47, Bcast: 169.254.255.255, Mask: 255.255.0.0
        MTU: 1500, Metric: 0, up broadcast auto-configured
        Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
        Transmit: 9 packets, 0 errors, 2673 bytes, 0 mcasts, 0 dropped
        Collisions: 0

instead of the original

~> ifconfig
/dev/net/atheroswifi/0
        Hardware Type: Ethernet, Address: 00:24:2b:1d:ae:cd
        inet addr: 192.168.1.14, Bcast: 192.168.1.255, Mask: 255.255.255.0
        MTU: 1500, Metric: 0, up broadcast link auto-configured configuring
        Receive: 16 packets, 0 errors, 6854 bytes, 0 mcasts, 0 dropped
        Transmit: 16 packets, 1 errors, 4313 bytes, 0 mcasts, 0 dropped
        Collisions: 0

/dev/net/rtl81xx/0
        Hardware Type: Ethernet, Address: 00:23:8b:54:d7:04
        inet addr: 
        MTU: 1500, Metric: 0, up broadcast configuring
        Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
        Transmit: 6 packets, 0 errors, 1782 bytes, 0 mcasts, 0 dropped
        Collisions: 0

Change History (9)

comment:1 by bbjimmy, 9 years ago

This happens to me on my eeepc, but only if there are more thanone wireless networks available. In these cases I need to change to a static ip then re-boot. The system will then maintain a connection. Without the re-boot, it will use dhcp and then change the ip to 169.254.0.113 and the connection is dead again.

Last edited 9 years ago by bbjimmy (previous) (diff)

comment:2 by deejam, 8 years ago

Is this error still present? If it is, please attach the syslog showing the DHCP logging when this occured. The description in this ticket is not enough to be able to spot the problem.

comment:3 by modeenf, 8 years ago

Cc: modeenf added

I Will test this to :)

comment:4 by diver, 7 years ago

Component: - GeneralNetwork & Internet/Wireless
Description: modified (diff)
Owner: changed from nobody to axeld

Is it still reproducible?

comment:5 by diver, 7 years ago

Description: modified (diff)

comment:6 by diver, 7 years ago

Component: Network & Internet/WirelessServers/net_server

Actually it looks like a dhcp issue. Changing component.

comment:7 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:8 by waddlesplash, 12 months ago

Please retest with a recent nightly.

comment:9 by waddlesplash, 7 months ago

Resolution: invalid
Status: assignedclosed

No reply, closing.

Note: See TracTickets for help on using tickets.