Opened 9 years ago

Closed 9 years ago

#6327 closed bug (invalid)

missing libstdc++.r4.so [r37693]

Reported by: Disreali Owned by: mmadia
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I just build and installed hrev37537-4h and then used 'installoptionalpackage' to install Bezilla. When I attempted to launch Bezilla and error box popped up that said "Could not open "BezillaBrowser" (Missing libraries: libstdc++.hrev4.so).

Attachments (1)

r37537_bezilla_missinglibstdc++.png (121.2 KB ) - added by Disreali 9 years ago.

Download all attachments as: .zip

Change History (5)

by Disreali, 9 years ago

comment:1 by mmadia, 9 years ago

Owner: changed from nobody to mmadia
Status: newin-progress

comment:2 by mmadia, 9 years ago

Resolution: invalid
Status: in-progressclosed

The build was configured improperly as a gcc4 + gcc4(altdir). This was confirmed by looking at ls -lha of /boot/system/lib/ , gcc4/ and gcc2/. lib/ contained the gcc4 libs as expected. gcc2/ only contained the ICU 4.4.x libs, and gcc4/ contained a copy of the gcc4 libs (minus ICU 4.4).

installoptionalpackages DetectSystemConfiguration() http://dev.haiku-os.org/browser/haiku/trunk/data/bin/installoptionalpackage#L385 treated the system as a GCC2 hybrid, because /boot/system/lib/gcc4 exists. AboutSystem treated the system as a GCC4 hybrid because GNUC = 4 and BEntry gccFourHybrid exists http://dev.haiku-os.org/browser/haiku/trunk/src/apps/aboutsystem/AboutSystem.cpp#L500

comment:3 by streak, 9 years ago

Resolution: invalid
Status: closedreopened
Summary: Bezilla missing libstdc++.r4.somissing libstdc++.r4.so [r37693]

GCC4H hrev37693 [downloaded from haiku-files] missing libstdc++.hrev4.so and BeZilla and BePDF not work..

comment:4 by mmadia, 9 years ago

Resolution: invalid
Status: reopenedclosed

If libstdc++.hrev4.so is missing, then you are not running a gcc4 hybrid

Note: See TracTickets for help on using tickets.