Opened 9 years ago

Closed 9 years ago

#6357 closed bug (fixed)

Deskbar clock doesn't update live when selecting 12h time

Reported by: luroh Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Rev 37675, gcc2.

The problem seems to occur only at AM hours (set your clock accordingly to reproduce):

Using the Locale preflet, select 24h time (note the live update of the Deskbar clock) and reboot.

Launch the Locale preflet again and select 12h --> the Deskbar clock is not updated properly until after a reboot.

Change History (2)

comment:1 Changed 9 years ago by pulkomandy

Component: Preferences/LocaleApplications/Deskbar
Owner: changed from pulkomandy to axeld

This is apparently not a bug in the locale kit. Actually, the AM/PM string gets here, but the deskbar doesn't update the space needed for it, so it's out of screen. Moving the deskbar solve the problem, forcing a relayout of the elements in the tray.

comment:2 Changed 9 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Fixed in hrev37677

Note: See TracTickets for help on using tickets.