Opened 9 years ago

Closed 9 years ago

#6376 closed bug (duplicate)

Quicktime movie works in Clockwerk but not in MediaPlayer and VLC

Reported by: brunobratwurst Owned by: dlmcpaul
Priority: normal Milestone: R1
Component: Audio & Video/Codecs Version: R1/alpha2
Keywords: mjpeg, video, clockwerk Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I use a cannon foto camera to make short movies. mjpeg movies whith 30fps.

The video files will be saved in a mov container...

If i try to play them with double click in Media Player the video is destorted. divided.

If iI try to play the files in VLC I get the correct picture and sound but the output in Bitmapnot smoth it is very choppy.

If I make a new project in clockwerk and import this video files they play most fine.

Change History (8)

comment:1 by brunobratwurst, 9 years ago

comment:2 by stippi, 9 years ago

Blocking: 6569 added

comment:2 by stippi, 9 years ago

Blocking: 6569 removed
Owner: changed from nobody to dlmcpaul
Status: newassigned

David, the bug is in the color space conversion code. If USE_SWS_FOR_COLOR_SPACE_CONVERSION is defined to 1 on line 43 of the AVCodecDecoder.cpp, then the video plays fine.

comment:3 by stippi, 9 years ago

Blocked By: 5846 added
Resolution: duplicate
Status: assignedclosed

comment:4 by stippi, 9 years ago

Blocked By: 5846 removed

(In #5846) David, the bug is in the color space conversion code. If USE_SWS_FOR_COLOR_SPACE_CONVERSION is defined to 1 on line 43 of the AVCodecDecoder.cpp, then the video plays fine.

comment:5 by brunobratwurst, 9 years ago

The video still does not work...

Where to change the color space conversion? Just downloaded Haiku Version 38969 and tried it, still same problem as before...

comment:6 by brunobratwurst, 9 years ago

Resolution: duplicate
Status: closedreopened
Type: enhancementbug

comment:7 by stippi, 9 years ago

Resolution: duplicate
Status: reopenedclosed

When a ticket is marked as duplicate of some other ticket, it does not mean the issue is actually fixed. Just look up the other ticket, and please don't reopen bugs which I cleaned up, it just caused more work for me for a stupid reason.

The comment about where the bug is was just for David. If David does not comment, I may temporarily fix the problem by switching from Davids color space conversion to an alternative version which is slower but does not exhibit this problem.

Note: See TracTickets for help on using tickets.