Opened 9 years ago

Closed 9 years ago

#6387 closed bug (fixed)

Typing inside terminal overwrites the same line when reaches the end of a line

Reported by: michaelvoliveira Owned by: jackburton
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: terminal typing line Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I don't know how describe it

but since Alpha2 release when I type, Terminal don't change to the next line at the end of the line.. it continues from beggining, overwriting everything...

But an image can figure it out

Attachments (1)

screenshot1.png (20.0 KB) - added by michaelvoliveira 9 years ago.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by michaelvoliveira

Attachment: screenshot1.png added

comment:1 Changed 9 years ago by Adek336

Could you post the output of the shopt builtin?

comment:2 Changed 9 years ago by Karvjorm

I have noticed that this happens when you change the size of the terminal window. No problems with the original terminal window size.

comment:3 Changed 9 years ago by Adek336

shopt -s checkwinsize should be put into a profile or bashrc file.

comment:4 Changed 9 years ago by michaelvoliveira

shopt
autocd          off
cdable_vars     off
cdspell         off
checkhash       off
checkjobs       off
checkwinsize    on
cmdhist         on
compat31        off
compat32        off
dirspell        off
dotglob         off
execfail        off
expand_aliases  on
extdebug        off
extglob         off
extquote        on
failglob        off
force_fignore   on
globstar        off
gnu_errfmt      off
histappend      off
histreedit      off
histverify      off
hostcomplete    on
huponexit       off
interactive_comments    on
lithist         off
login_shell     on
mailwarn        off
no_empty_cmd_completion off
nocaseglob      off
nocasematch     off
nullglob        off
progcomp        on
promptvars      on
restricted_shell        off
shift_verbose   off
sourcepath      on
xpg_echo        off

Seems that Karvjorm are right this time. This bug occours because I set font size in Font preflet to 13 or 14. If inside terminal I choose definitions menu -> decrease text size and after increase text size all back to normal

comment:5 Changed 9 years ago by augiedoggie

Possibly related to #6102. I had odd problems similar to this due to using a custom font and Terminal not setting the font properly until after the size of the view was calculated.

comment:6 Changed 9 years ago by bonefish

Has that been fixed together with #6102? At least I can't reproduce playing with the font size.

comment:7 Changed 9 years ago by michaelvoliveira

Ah..!! it's fixed already!

Sorry for delay

Thank you!!

It was very annoying

comment:8 Changed 9 years ago by bonefish

Resolution: fixed
Status: newclosed

Thanks for the update.

Note: See TracTickets for help on using tickets.