Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6405 closed bug (fixed)

Unable to disable wireless interface

Reported by: pulkomandy Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I use wired network on my laptop and usually disable the wireless card to not be annoyed with connections to random access points floating around.

However, something in the last two days completely broken disabling an interface. I tried both the network preferences panel and the ifconfig command line. Both gave me a kernel panic in the same place. It seems 100% reproductible.

The panic is triggered in headers/private/kernel/util/DoublyLinkedList.h:512 , called from ethernet_down.

I wasn't sure what to do from there, so please tell me if I can help debugging it in any way. I didn't try doing the same on another network interface.

Change History (4)

comment:1 Changed 9 years ago by axeld

How exactly did you disable the interface per ifconfig? I could imagine that the UI change might work after a reboot, though.

Apart from that, removing interfaces is currently not implemented since I reworked the stack internals. I'll fix that later.

comment:2 Changed 9 years ago by pulkomandy

I simply did ifconfig /dev/net/atheroswifi/0 down , and it crashed the same way as in the GUI. Currently I work around this by setting it to a dummy static IP, so that it just can't work.

comment:3 Changed 9 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Works fine again as of hrev37894.

comment:4 Changed 9 years ago by axeld

That's not entirely satisfying, as I couldn't reproduce that bug. Maybe hrev37872 or hrev37884 made a difference, though.

Note: See TracTickets for help on using tickets.