Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#6410 closed bug (duplicate)

Deskbar menu still reacting to mouse when obscured

Reported by: tHe_IkkE Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Deskbar menu focus Cc:
Blocked By: #6408 Blocking:
Has a Patch: no Platform: All

Description

When you select the deskbar menu and then select a window (tried with stylededit and webpositive) overlapping the menu, the menu stays active (not so bad) but when you move the cursor over a (now invisible) menu-item that has a sub-menu, the submenu is shown OVER the current window without the menu itself being visible.

Tested in VirtualBox with Alpha2 and nightly of 29th of Juli (hrev37816).

See attached screenshot.

Attachments (1)

Picture 2.png (349.8 KB ) - added by tHe_IkkE 9 years ago.
Screenshot of VirtualBox running haiku

Download all attachments as: .zip

Change History (8)

by tHe_IkkE, 9 years ago

Attachment: Picture 2.png added

Screenshot of VirtualBox running haiku

comment:1 by humdinger, 9 years ago

FWIW, I can't reproduce this on VB3.2 under Ubuntu with r378xx or natively with hrev37437. As soon as I click the overlapping window the Deskbar menu collapses and deactivates. I also tried with different mouse focus settings. Same result. Maybe a VB on OSX thing?

in reply to:  1 comment:2 by tHe_IkkE, 9 years ago

Replying to humdinger:

FWIW, I can't reproduce this on VB3.2 under Ubuntu with r378xx or natively with hrev37437. As soon as I click the overlapping window the Deskbar menu collapses and deactivates. I also tried with different mouse focus settings. Same result. Maybe a VB on OSX thing?

I ran the test again using Q (kju) on OSX with the alpha2 install disc in "live" mode and I got the same (errornous) results. But I don't think the (virtual) machine has anything to do with this.

comment:3 by axeld, 9 years ago

I also saw this a while ago - the correct behaviour would be to activate the menu as long as the app is alive.

comment:4 by axeld, 9 years ago

Component: User InterfaceKits/Interface Kit
Owner: changed from stippi to axeld

comment:5 by diver, 7 years ago

Version: R1/alpha2R1/Development

Still here in hrev44622.

comment:6 by diver, 6 years ago

Resolution: duplicate
Status: newclosed

Most likely a dupe of #6408.

comment:7 by diver, 6 years ago

Blocked By: 6408 added
Note: See TracTickets for help on using tickets.