Opened 9 years ago

Closed 7 years ago

#6476 closed bug (fixed)

[DiskProbe] crashes in BString::Prepend ()

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/DiskProbe Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev38299 in VirtualBox 3.0.12

First of all, DiskProbe sees unavailable atapi device. Upon selection DiskProbe crashes. Curiously terminal window with GDB titled as "-t"

Thread 1353 caused an exception: Segment violation
[...]
[Switching to team /boot/system/apps/DiskProbe (1353) thread DiskProbe (1353)]
0x00465c9c in BString::Prepend () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x00465c9c in BString::Prepend () from /boot/system/lib/libbe.so
#1  0x0022f6da in HeaderView::HeaderView ()
#2  0x00232de4 in ProbeView::ProbeView ()
#3  0x0022791a in FileWindow::FileWindow ()
#4  0x0021e2ed in DiskProbe::Probe ()
#5  0x0021e5de in DiskProbe::RefsReceived ()
#6  0x00329656 in BApplication::DispatchMessage ()
   from /boot/system/lib/libbe.so
#7  0x00334471 in BLooper::task_looper () from /boot/system/lib/libbe.so
#8  0x003282e9 in BApplication::Run () from /boot/system/lib/libbe.so
#9  0x0021f21b in main ()
(gdb)

Attachments (1)

DiskProbe.png (28.5 KB ) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (8)

by diver, 9 years ago

Attachment: DiskProbe.png added

comment:1 by diver, 9 years ago

Crash happens after clicking Probe device button.

comment:2 by diver, 9 years ago

Also, cdrom is not attached to Haiku in vm settings.

comment:3 by axeld, 9 years ago

Is there any reason you are using such an old version of VirtualBox, btw?

comment:4 by diver, 9 years ago

Unfortunately, I still have to use Fedora 8 and vbox 3.0.12 is the last version available. But if needed I can recheck it on my girlfriend's PC with latest version of VirtualBox.

comment:5 by axeld, 9 years ago

That won't be necessary in this particular case - I was just wondering :-)

comment:6 by diver, 9 years ago

Can't reproduce after hrev38828.

comment:7 by stpere, 7 years ago

Resolution: fixed
Status: newclosed

reported fixed in hrev38828.

Note: See TracTickets for help on using tickets.