Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#652 closed bug (fixed)

BTextView doesnt redraw correctly after text selection

Reported by: johndrinkwater Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The text box draws the characters without clearing first; this results in overlayed text (anti-aliasing builds up) hrev17690

Attachments (1)

addon-text.png (2.8 KB ) - added by johndrinkwater 13 years ago.
BTextView showing glyph buildup

Download all attachments as: .zip

Change History (11)

comment:1 by korli, 13 years ago

I can't reproduce this. Could it be a BTextView bug ?

comment:2 by johndrinkwater, 13 years ago

Summary: [Keymap] Typing field doesnt redraw correctlyBTextView doesnt redraw correctly after text selection

comment:3 by johndrinkwater, 13 years ago

Owner: changed from korli@… to axeld

comment:4 by johndrinkwater, 13 years ago

Component: PreferencesKits

retested, it is indeed a BTextView bug, steps to reproduce,

1, type some text, 2, select all text, 3, deselect text, 4, continue typing

Characters begin to thicken after each key press (attachment coming)

comment:5 by axeld, 13 years ago

Owner: changed from axeld to jackburton

by johndrinkwater, 13 years ago

Attachment: addon-text.png added

BTextView showing glyph buildup

comment:6 by jackburton, 13 years ago

Status: newassigned

comment:7 by jackburton, 13 years ago

Should be gone in hrev17863. Can you confirm ?

comment:8 by johndrinkwater, 13 years ago

Resolution: fixed

comment:9 by johndrinkwater, 13 years ago

Status: assignedclosed

comment:10 by johndrinkwater, 13 years ago

hrev17863 does indeed fix this issue, be aware that there's a new bug from it, will type up in a min.

Note: See TracTickets for help on using tickets.