Opened 9 years ago

Closed 9 years ago

#6530 closed bug (fixed)

[Terminal] Artifacts in drawing of window. Part II.

Reported by: siarzhuk Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Observed on hrev38437

Artifact # 1:
1) Open new Terminal window;
2) Press Alt-Enter to switch into Fullscreen mode;
3) Problem: Look on right part - there is quasy-transparent area between window client area and vertical scrollbar:
4) If this issue is still not observed on your system - press Ctrl-Tab to make some another window above the Terminal one and move this another window in vertical direction overlapping right part of the Terminal client area - there will be garbage in the right part of the Terinal client area.

Artifact # 2:
5) Vertical scrollbar in Full Screen mode neither drawn correctly (gray rectangle instead of scrollbar controls) nor functional (pressing on it doesn't scroll anything in client area).

Attachments (1)

terminal-artifacts.png (7.7 KB) - added by bonefish 9 years ago.
Terminal artifacts when moving another window over it

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by bonefish

Another, easy way to reproduce artifacts (hrev38606):

  1. Open new Terminal window with standard size.
  2. Enlarge it by a few pixels.
  3. Move another window over the Terminal.

Probably what is listed in the description under #1: On the right side, left to the margin the pixel colums that don't make up a complete character column apparently aren't cleared anymore. The region below the bottom character line has a similiar issue. Though, interestingly, the artifacts there are always black and are cleared sometimes.

Changed 9 years ago by bonefish

Attachment: terminal-artifacts.png added

Terminal artifacts when moving another window over it

comment:2 Changed 9 years ago by Disreali

I've been experiencing this issue since before hrev38400. I will try to narrow it down as soon as I have access to my Haiku systems.

comment:3 in reply to:  2 Changed 9 years ago by bonefish

Replying to Disreali:

I've been experiencing this issue since before hrev38400. I will try to narrow it down as soon as I have access to my Haiku systems.

At least the issues I was commenting on were introduced in hrev38316/hrev38317. I also commented on those changesets. Should be easy to fix, if someone takes the time to do it.

comment:4 Changed 9 years ago by phoudoin

The artifact #1 should be now fixed since hrev38783.

Last edited 9 years ago by phoudoin (previous) (diff)

comment:5 Changed 9 years ago by phoudoin

The artifact #2 should be fixed too since hrev38784. The scrollbar was hidden for no reason when there is only one tab.

comment:6 Changed 9 years ago by siarzhuk

Resolution: fixed
Status: newclosed

Checked on hrev38787. Result is perfect. Thank you.

Note: See TracTickets for help on using tickets.