Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6547 closed bug (fixed)

Fixes for more layout problems in AboutSystem and Installer caused by r38512

Reported by: jstressman Owned by: yourpalal
Priority: normal Milestone: R1
Component: Applications/AboutSystem Version: R1/Development
Keywords: Cc: jstressman@…
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

A small patch for some more layout problems in Installer and AboutSystem caused by the layout changes in hrev38512

This is my first patch ever for Haiku, so please let me know if it's ok.

Attachments (3)

layout-fixes.diff (1.2 KB ) - added by jstressman 9 years ago.
small layout fixes to InstallerWindow.cpp and AboutSystem.cpp
spacing-bugs3.png (61.6 KB ) - added by jstressman 9 years ago.
what the layout bugs look like (this was on a "release" build target, but is hrev38524 )
spacing-bugs-fixed1.png (101.0 KB ) - added by jstressman 9 years ago.
hrev38524 with the patch applied.

Download all attachments as: .zip

Change History (6)

by jstressman, 9 years ago

Attachment: layout-fixes.diff added

small layout fixes to InstallerWindow.cpp and AboutSystem.cpp

by jstressman, 9 years ago

Attachment: spacing-bugs3.png added

what the layout bugs look like (this was on a "release" build target, but is hrev38524 )

by jstressman, 9 years ago

Attachment: spacing-bugs-fixed1.png added

hrev38524 with the patch applied.

comment:1 by anevilyak, 9 years ago

Owner: changed from nobody to yourpalal
Status: newassigned

comment:2 by yourpalal, 9 years ago

Resolution: fixed
Status: assignedclosed

Basically applied in hrev38526, something was odd with your patch, the spacing at the start of the lines was off, so the patch wouldn't apply cleanly. I'm not sure what would have caused this, but since it was a small patch, I just made the changes manually. Thanks for the eyes and the code, jstressman!

comment:3 by stippi, 9 years ago

Has a Patch: set
Note: See TracTickets for help on using tickets.