Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6566 closed bug (fixed)

SATDecorator crash app_server

Reported by: X512 Owned by: czeidler
Priority: normal Milestone: R1
Component: Add-Ons/Decorators/Default Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev38526. When windows moving to stack with another window app_server crash sometimes.

Attachments (2)

bt.png (25.9 KB ) - added by X512 9 years ago.
SATDecorator-app_server-crash-serial.log (4.9 KB ) - added by mmadia 9 years ago.
crash from BeZillaBrowser "Close Other Tabs" in context menu

Download all attachments as: .zip

Change History (10)

by X512, 9 years ago

Attachment: bt.png added

comment:1 by anevilyak, 9 years ago

Owner: changed from axeld to czeidler
Status: newassigned

comment:2 by czeidler, 9 years ago

can't reproduce it, what are you exactly doing? which windows? which order?... thanks

by mmadia, 9 years ago

crash from BeZillaBrowser "Close Other Tabs" in context menu

comment:3 by mmadia, 9 years ago

This appears to be similar to an app_server crash that I can reproduce. In hrev38711-gcc2hybrid, launch multiple browser tabs in BeZillaBrowser, right click one and select "Close Other Tabs". Attached is a serial log snippet of the crash and a best guess as to some KDL commands.

If it'll help you, we can set up a ssh-based serial debug session (ssh in to my FreeBSD box and control kdebug via serial_input)

comment:4 by anevilyak, 9 years ago

From a quick glance it's possible this is due to some faulty assumptions in the SATDecorator. Most notably, a window created with the B_NO_BORDER_WINDOW_LOOK window look constant has no decorator, while StackAndTile seems to assume that if it managed to get a window, a decorator exists.

comment:5 by diver, 9 years ago

See also #6615.

comment:6 by czeidler, 9 years ago

Fixed in hrev38728 / hrev38729. Hey X512 you get the beer :-) if you attend to BeGeistert.

comment:7 by czeidler, 9 years ago

Resolution: fixed
Status: assignedclosed

comment:8 by diver, 9 years ago

Component: Servers/app_serverAdd-Ons/Decorators/Stack And Tile
Note: See TracTickets for help on using tickets.