Opened 9 years ago

Closed 9 days ago

#6568 closed bug (fixed)

[emuxki] Playing mp3 repeatedly causes distorted sound

Reported by: idefix Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/emuxki Version: R1/Development
Keywords: emuxki Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When MediaPlayer plays the tested mp3 file the first time, it sound normal. However, repeated plays causes distortion.

Steps to reproduce:

  1. Play the tested mp3 file in MediaPlayer
    • notice that the sound is normal
  2. Press space to play it again
    • notice that the sound is slightly distorted
  3. Press space to play it again
    • notice that the sound is heavenly distorted (sounds like an inverted echo)

It might take a couple of repeats longer to get the heavenly distorted sound.

Tested on hrev38581 with an Emuxki SB Live 5.1 sound card (real-time audio enabled).

VLC plays the mp3 fine no matter how many times it repeats.

Output from MediaPlayer when playing the file:

~/downloads> MediaPlayer ./geleidelijn.dv.ingang_busstation.spoor_4a+b.mp3 
MainApp::ArgvReceived ./geleidelijn.dv.ingang_busstation.spoor_4a+b.mp3
MainApp::ArgvReceived calling RefsReceived
MainWin::MessageReceived: B_REFS_RECEIVED
open playlist item: geleidelijn.dv.ingang_busstation.spoor_4a+b.mp3
asfReader::asfReader
asfReader::Sniff
asfReader::Sniff: unsupported file type
[mp3 @ 0x180be0f0]max_analyze_duration reached
[mp3 @ 0x180be0f0]Estimating duration from bitrate, this may be inaccurate
running without video node
BMediaEventLooper: SchedulingLatency is 750
BMediaRoster::Connect connection established!
performance time for 10297617382: 10232614009
B_START: start time: 10232714009
[mp2 @ 0x18103f60]incomplete frame
########### audio decode error, fChunkBufferSize 46, fChunkBufferOffset 0
BMediaTrack::ReadFrames: decoder returned error 0x80004007 (Last buffer)
########### audio decode error, fChunkBufferSize 46, fChunkBufferOffset 0
GetNextChunk error 0
key 0x5e, rawChar 0x20, modifiers 0x0
########### audio decode error, fChunkBufferSize 46, fChunkBufferOffset 0
BMediaTrack::ReadFrames: decoder returned error 0x80004007 (Last buffer)
########### audio decode error, fChunkBufferSize 46, fChunkBufferOffset 0
GetNextChunk error 0
key 0x5e, rawChar 0x20, modifiers 0x0
########### audio decode error, fChunkBufferSize 46, fChunkBufferOffset 0
BMediaTrack::ReadFrames: decoder returned error 0x80004007 (Last buffer)
########### audio decode error, fChunkBufferSize 46, fChunkBufferOffset 0
GetNextChunk error 0
key 0x5e, rawChar 0x20, modifiers 0x0
AudioProducer::_FillNextBuffer() - no buffer (size: 3528, duration: 40000)
key 0x28, rawChar 0x77, modifiers 0x402
BMediaRoster::ReleaseNode, trying to release reference counting disabled timesource, node 2, port 241774, team 7552
~/downloads> 

The sound gets heavenly distorted after AudioProducer::_FillNextBuffer() - no buffer (size: 3528, duration: 40000) appears in the log.

Change History (10)

comment:1 Changed 9 years ago by stippi

Cannot reproduce.

comment:2 Changed 9 years ago by anevilyak

FWIW I have a similar problem on an emuxki chipset, albeit not quite this predictable. In my case iirc restarting media_server fixes it. Haven't tested this since Stephan's recent changes though.

comment:3 in reply to:  2 ; Changed 9 years ago by idefix

Replying to stippi:

Cannot reproduce.

Bummer. :)
I will try to reproduce it on another computer this weekend (altough I'm not sure if its sound card is working in Haiku).

Replying to anevilyak:

FWIW I have a similar problem on an emuxki chipset, albeit not quite this predictable. In my case iirc restarting media_server fixes it. Haven't tested this since Stephan's recent changes though.

I don't need to perform such drastic measures, after restarting MediaPlayer it will play correctly again for some time.

comment:4 in reply to:  3 Changed 9 years ago by anevilyak

Replying to idefix:

I don't need to perform such drastic measures, after restarting MediaPlayer it will play correctly again for some time.

It's most probably a different issue then, mine also only really starts to appear after quite a few hours of uptime. The symptoms sound quite similar though, increasing distortion during playback.

comment:5 in reply to:  3 Changed 9 years ago by idefix

Component: Applications/MediaPlayerDrivers/Audio
Keywords: emuxki added
Owner: changed from stippi to korli
Summary: Playing mp3 repeatedly causes distorted sound[emuxki] Playing mp3 repeatedly causes distorted sound

Replying to idefix:

Replying to stippi:

Cannot reproduce.

Bummer. :)
I will try to reproduce it on another computer this weekend (altough I'm not sure if its sound card is working in Haiku).

I couldn't reproduce it on a laptop with an HDA sound card, so it's most likely a problem with the emuxki driver.

comment:6 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/emuxki

comment:7 Changed 2 weeks ago by waddlesplash

Still an issue?

comment:8 Changed 2 weeks ago by idefix

No idea, haven't used that card in years.
Will have to digg it up from one of my moving boxes and test again...

comment:9 Changed 9 days ago by idefix

Dug up the card and put it in a different pc (the original has been disposed of years ago).

I couldn't reproduce the issue. The file plays without any distortion everytime.

This ticket can be closed.

comment:10 Changed 9 days ago by waddlesplash

Resolution: fixed
Status: newclosed

Thanks for testing! If you have time to retest your other old tickets, that would be helpful :)

Note: See TracTickets for help on using tickets.