Opened 9 years ago

Closed 9 years ago

#6582 closed bug (fixed)

MediaPlayer crash with mp4 file

Reported by: luroh Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by luroh)

Rev 38606, gcc2, VMware and real hw.

This file plays in hrev38547 but causes MP to crash in hrev38563 and later (the intermediate revisions don't build): http://deathstar.knuttinatoll.net/hammer/jambalaya.mp4 (20 MB)

May be a dupe of #6561.

Attachments (1)

gdb.txt (5.4 KB) - added by luroh 9 years ago.

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by luroh

Attachment: gdb.txt added

comment:1 Changed 9 years ago by luroh

Description: modified (diff)

comment:2 Changed 9 years ago by stippi

Cannot reproduce, the file plays fine here (GCC4 image).

comment:3 Changed 9 years ago by luroh

You are right, it only affects gcc2 and gcc2h builds, not gcc4 or gcc4h ones.

comment:4 Changed 9 years ago by stippi

Description: modified (diff)

Some optimizations are turned off for the GCC2 build. Or GCC2 may generate invalid code from some assembler.

comment:5 Changed 9 years ago by stippi

Can you make your own builds? If so, you could revert individual changes from hrev38562. Start with the run-time CPU detection (revert it if it doesn't have any effect), the registers, then SSE and so on, until the file plays again. Then we know what we have to disable for GCC2.

comment:6 Changed 9 years ago by luroh

Thanks for the suggestion, I'll try that and revert.

comment:7 Changed 9 years ago by luroh

#define CONFIG_RUNTIME_CPUDETECT 0 makes MP stop crashing to gdb as described above ("corrupt stack?"). Instead, it exits silently. When running MP from a Terminal window, the following output can be observed:

~> MediaPlayer 
MainWin::MessageReceived: B_SIMPLE_DATA
open playlist item: jambalaya.mp4
asfReader::asfReader
asfReader::Sniff
asfReader::Sniff: unsupported file type
Abort
Killed (by death)
~>

Reverting any of the other changes in hrev38562 does seemingly not make any difference.

comment:8 Changed 9 years ago by luroh

Description: modified (diff)

Regression range updated.

comment:9 Changed 9 years ago by luroh

Sorry, strike that - with hrev38706, MP crashes to gdb like before, no matter what changes from hrev38562 I revert.

comment:10 Changed 9 years ago by stippi

Resolution: fixed
Status: newclosed

Fixed in hrev38746.

Note: See TracTickets for help on using tickets.