Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#659 closed bug (fixed)

if the volume has 30-26 MBytes free space can 't be created files

Reported by: kaoutsis@… Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

if the volume has 30-26 MBytes free space, can't be created files neither by me neither by the system, nor the applications can create config_files.

Attachments (1)

no-space.txt (1.2 KB) - added by kaoutsis@… 13 years ago.
some informations from the shell

Download all attachments as: .zip

Change History (7)

comment:1 Changed 13 years ago by diver

Cc: diver added

Changed 13 years ago by kaoutsis@…

Attachment: no-space.txt added

some informations from the shell

comment:2 Changed 13 years ago by axeld

I can't reproduce this. How old is your partition? What did you do with it before? Does running "chkbfs" under BeOS report any errors?

comment:3 Changed 13 years ago by kaoutsis@…

a) chkbfs does not find errors. b) the partition has been created about 3 mounths ago.

(if you ask me about the hard disk history is very old, ~7 years :) )

c) before haiku, this partitions has a R5 working (without virtual merory),

just for playing (~1-2 weeks). and before R5, a DSL linux and puppy linux!

May be the problem is the size of the partition (~95 Mb), did you also check that?

comment:4 Changed 13 years ago by kaoutsis@…

the problem is not the size of the partition, because after some playing around i find this: initialize the filesystem of the partition with block size 1024, reading-writiing-creating new files is ok, initialize the filesystem of the partition with block size 2048, reading-writiing-creating new files is ok the issue now is this: initialize the filesystem of the partition with block size 4096, reading and writing existing files is ok but, the filesystem can not create new files.

comment:5 Changed 13 years ago by axeld

Description: modified (diff)
Platform: All
Resolution: fixed
Status: newclosed

Fixed in hrev18955.

comment:6 in reply to:  5 Changed 13 years ago by kaoutsis

Replying to axeld:

Fixed in hrev18955.

i confirm that Axel. I initialized the filesystem of the partition with block size 4096 and now creates files. Thanks.

Note: See TracTickets for help on using tickets.