Opened 9 years ago

Closed 8 years ago

#6600 closed bug (invalid)

TCP connection does not work - solved

Reported by: hitech Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/TCP Version: R1/alpha2
Keywords: networking, tcp, telnet, surfing Cc: ahitech@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I'm using the VMWare image, and had run into a strange problem with surfing and telnetting to web sites. The problem exists since R1a2, and I've experienced it in R1a2 official build and in R38627 nightly build; however, it does not exist in version R34784.

The problem is represented by the following behavior: I can ping and resolve just about any site on the Internet, but I can't browse to them or even telnet to them on port 80. The request is sent, but the answer is either not received or not treated properly.

Symptoms

  • Pings are fine → that means at least UDP works.
  • Using any browser to any site, both to the hostnames and to IPs → "Waiting for reply..." until timeout.
  • Telnet to any site on port 80 → "Trying <Correct IP>..." until timeout.
  • SSH to my account on Berlios.de or to my account at the university → No reply, then timeout.
  • SSH to an invalid host → I receive a message "Could not resolve hostname" (which is correct, thus resolving works).

Software

I'm using VMware Workstation 6.0.5 or VMware player 2.0.5.

Haiku versions which suffer from this problem are from R1a2 official to R38627 nightly including.

Attachment

The output of tcpdump while trying to telnet to www.haiku-os.org on port 80.

Attachments (1)

tcpdump.log (6.6 KB) - added by hitech 9 years ago.
tcpdump while trying to "telnet www.haiku-os.org 80"

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by hitech

Attachment: tcpdump.log added

tcpdump while trying to "telnet www.haiku-os.org 80"

comment:1 Changed 9 years ago by hitech

Cc: ahitech@… added
Version: R1/DevelopmentR1/alpha2

comment:2 Changed 9 years ago by hitech

In Hybrid GCC4 release 38828 the problem still persists.

However, in the same R38828 under VirualBox the networking works fine.

Last edited 9 years ago by hitech (previous) (diff)

comment:3 Changed 8 years ago by Coldfirex

hitech: What are your network settings in Vmware itself?

comment:4 Changed 8 years ago by hitech

I have tried several options in VMware: NAT and Bridged, namely.

comment:5 Changed 8 years ago by hitech

The bug still exists in R40925 GCC4 hybrid. I've tried all possible types of network cards, (vmxnet, e1000 (default) and vlance), and both NAT and Bridged connections, and none worked.

Last edited 8 years ago by hitech (previous) (diff)

comment:6 Changed 8 years ago by hitech

Ok, here's some good news:

In version R41138 GCC4 hybrid, I've succeeded to get on-line and surf the net in VMWare.

In order to accomplish this task, I had to create a new virtual machine, manually add it the boot disk, configure the Ethernet adapter to work in Bridged mode, edit the .vmx file in Notepad to specify the type of the adapter (I used e1000), create a DHCP-server in my home network, configure the Haiku to obtain the IP address automatically, and only then I succeeded to surf.

Still, I was unable to get online using the provided .vmx out of the box. I had to create a new virtual machine.

Considering success of my attempts to get online, this bug report may be set as low priority (or even closed).

comment:7 Changed 8 years ago by hitech

The problem returned again after I changed my host's IP address. Maybe it's the VMWare's guilt after all?.. How can I check it?

comment:8 Changed 8 years ago by hitech

Summary: TCP connection does not workTCP connection does not work - solved

Well, the problem was solved. It was VMWare's problem; I used the solution written here.

The bugreport should be closed.

comment:9 Changed 8 years ago by luroh

Resolution: invalid
Status: newclosed

That's good to hear, closing.

Note: See TracTickets for help on using tickets.