Opened 9 years ago

Last modified 4 years ago

#6616 reopened bug

[SATDecorator] clicking zoom button flickers window content

Reported by: diver Owned by: czeidler
Priority: normal Milestone: R1
Component: Add-Ons/Decorators/Default Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev38664.

Stack several Tracker windows (with lots of files) together. Clicking zoom button will flicker window content.

Attachments (2)

Tracker.ogv (897.5 KB) - added by diver 8 years ago.
flickering.ogv (4.1 MB) - added by diver 8 years ago.

Change History (15)

comment:1 Changed 8 years ago by diver

It got worse in recent revisions. Every click inside tracker produces several flickers. Most visible in VirtualBox, but visible on real hw too.

comment:2 Changed 8 years ago by diver

Component: Servers/app_serverAdd-Ons/Decorators/Stack And Tile
Owner: changed from axeld to czeidler

comment:3 Changed 8 years ago by czeidler

Resolution: fixed
Status: newclosed

Fixed in hrev42487, thanks.

comment:4 Changed 8 years ago by diver

Resolution: fixed
Status: closedreopened

After cleaning up objects:

rm -rf generated/objects/haiku/x86/release/servers/app/
rm -rf generated/objects/haiku/x86/release/add-ons/decorators/SATDecorator/

and updating to hrev42490 I can still reproduce this one.

comment:5 Changed 8 years ago by czeidler

Ah I think I see what you mean and its probably an other issue than before. You mean the flickering in the title bar? I notice the problem before, e.g. when shifting the tabs in a stack. The problem is that the decorator draws tabs on top of other tabs. This is normally double buffered but the drawing of the buttons triggers a synchronous redraw...

comment:6 Changed 8 years ago by czeidler

Resolution: fixed
Status: reopenedclosed

Hopefully finally fixed in hrev42493.

comment:7 Changed 8 years ago by diver

Resolution: fixed
Status: closedreopened

Still here in hrev42532.

Changed 8 years ago by diver

Attachment: Tracker.ogv added

comment:8 Changed 8 years ago by diver

Seems to be reproducible only with stacked tracker windows.

comment:9 Changed 8 years ago by czeidler

Resolution: fixed
Status: reopenedclosed

This is not a bug but normal and I also see it in terminal, probably every window. Try to stack two windows without S&T and you will see the same effect. The problem is that when you activate a window the complete window content is invalidated because it was not visible before and will be redrawn.

See Stippi's latest blog post if you are searching for a solution :-)

comment:10 Changed 8 years ago by diver

Resolution: fixed
Status: closedreopened

It's back again in hrev42615.

Changed 8 years ago by diver

Attachment: flickering.ogv added

comment:11 Changed 6 years ago by diver

I still think that it is a bug in S&T because the flickering only occurs when two different apps are stacked together. For instance, if you stack Terminal+Tracker and try to resize or zoom (like in the attached video) this group you see that Tracker's window content flickers and redraws slowly. Whereas if you stack two Tracker windows and try do the same there is no flickering whatsoever.

comment:12 Changed 4 years ago by luroh

Milestone: R1Unscheduled

Moving S&T related tickets out of R1 milestone (Prop #16).

comment:13 Changed 4 years ago by luroh

Milestone: UnscheduledR1

Moving S&T related tickets back into R1 milestone as S&T is in fact now the default. My apologies.

Note: See TracTickets for help on using tickets.