Opened 13 years ago

Closed 12 years ago

#668 closed bug (fixed)

Using other than the default font would disorder the text spacing in Terminal

Reported by: kutspam@… Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/Terminal Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

For revision of may 9th I changed fonts in the terminal (for checking if special Czech characters / glyphs which were missing in the other fonts as well) and by this the space between characters was wider and some additional tabs were rendered. Bluntly said; a mess were I couldn't tell were the end of the line was because when I would backspace it would delete more than I wanted to. Sort-of don't know where the cursor is.

Change History (9)

comment:1 by diver, 13 years ago

Cc: diver added

comment:2 by kutspam@…, 13 years ago

It appears this has to do with the weird size error, therefor this maybe should be a duplicate bug. Couldn't reproduce it.

comment:3 by jackburton, 13 years ago

Works well using KonatuTT (monospaced?) while it does not using any other font, beside Vera mono.

comment:4 by axeld, 13 years ago

Description: modified (diff)
Owner: changed from sikosis to axeld
Platform: All

comment:5 by axeld, 13 years ago

Owner: changed from axeld to stippi

The problem are monospaced fonts vs. non-monospaced fonts. Apparently, the app_server cannot yet use any font as monospaced font.

comment:6 by diver, 13 years ago

I must say that even when using default font settings, font in terminal could disorder the text spacing sometimes...

comment:7 by nielx, 12 years ago

Component: - Applications- Applications/Terminal

Move to the proper component

comment:8 by stippi, 12 years ago

There was a bug a while ago where font flags had not been transmitted correctly from or to the app_server, and it affected fixed width fonts too. Maybe this bug here has been fixed by my fix then? Could someone please confirm?

comment:9 by jackburton, 12 years ago

Resolution: fixed
Status: newclosed

No, this is a problem in terminal. For how it's written, Terminal can only used monospaced fonts. For the time being Terminal only let you select such fonts.

Note: See TracTickets for help on using tickets.