Opened 8 years ago

Closed 2 months ago

#6697 closed bug (fixed)

Atheros 9k mac address based login disconnects

Reported by: cb88 Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Steps to reproduce problem in my case: boot haiku

get wifi working (required that I fill in some info manually then set to static otherwise the link wouldn't come up)

open Web+ acess login page (this nearly always works correctly)

login

Then several things may happen: redirects then locks up. redirects incorrectly back to login page. redirects correctly and then stops working after a few seconds or minutes.

My school apparently uses Miro APs which have unencrypted access and block acess via mac address blocking (I think)

wlan0 Link encap:Ethernet HWaddr 70:1A:04:46:C7:AC

inet addr:192.168.16.146 Bcast:192.168.19.255 Mask:255.255.252.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:2731 errors:0 dropped:0 overruns:0 frame:0 TX packets:2601 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:3072930 (2.9 Mb) TX bytes:424746 (414.7 Kb)

I can upload any logs that would be useful in debugging as I have haiku installed to my HD once again. There are possibly problems in several areas the browser the driver and the ip/dns configuration etc.... the driver seems fine it runs fast enough when it does connect. There is a open ap at another school I know of that I will also try on I imagine it works fine there.

Change History (4)

comment:1 Changed 8 years ago by cb88

Also this isn't a recent development it has been this way ever since I tried the wifi driver some months back.

comment:2 Changed 5 months ago by waddlesplash

Still an issue?

comment:3 Changed 5 months ago by cb88

Well... possibly I still have that laptop. But that's been quite some time ago and I'm pretty sure I couldn't duplicate the exact conditions.

I say close it and if I run into it again I'll let you know. Chances are it's been fixed as the wifi stack was pretty new back then...

comment:4 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.