Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#6743 closed bug (fixed)

Time zone preview inaccurate

Reported by: Disreali Owned by: leavengood
Priority: normal Milestone: R1
Component: Preferences/Time & Date Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On hrev39041, the Time preflet's time zone preview shows the same time as the currently selected time zone.

Attachments (1)

time_pref_tzone-preview_fail.png (18.4 KB) - added by Disreali 9 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by Disreali

comment:1 Changed 9 years ago by zooey

Is your hardware clock (in the other tab) set to "Local Time" or "GMT"?

If it's "Local Time", no time adjustments will happen when you select another timezone, as you are then just specifying the timezone of that specific time. Only for "GMT" the local time will be adjusted according to the selected timezone.

comment:2 Changed 9 years ago by axeld

Maybe then just hide the preview in the local time case?

comment:3 in reply to:  1 Changed 9 years ago by Disreali

Replying to zooey:

Is your hardware clock (in the other tab) set to "Local Time" or "GMT"?

It was set to Local.

If it's "Local Time", no time adjustments will happen when you select another timezone, as you are then just specifying the timezone of that specific time. Only for "GMT" the local time will be adjusted according to the selected timezone.

I don't remember other OS's behave this way. Though, I'd have to check to be sure. I still think it should work when set to 'Local Time', but then I have little idea of how the coding actually works. Thanks.

comment:4 Changed 8 years ago by leavengood

Owner: changed from axeld to leavengood
Status: newin-progress

Any more ideas on this? My mind is fresh on the Time preflet since I've been working on it and I'd like to finish off some of these lingering bugs.

I think Oliver is right in that if the hardware clock is set to local time then that is your time, and setting the time zone isn't really needed. Now the question is how to best handle that without confusing users. The preview is certainly misleading in that case so maybe it should just be hidden as Axel says?

I'll take ownership nonetheless.

comment:5 in reply to:  4 Changed 8 years ago by zooey

Replying to leavengood:

I think Oliver is right in that if the hardware clock is set to local time then that is your time, and setting the time zone isn't really needed.

But I never said that: of course it is important to set the time zone, as otherwise the times written to filesystems (usually in UTC) would use the wrong offset. Many networking apps will show incorrect times, too, if the timezone hasn't been set correctly.

Now the question is how to best handle that without confusing users. The preview is certainly misleading in that case so maybe it should just be hidden as Axel says?

I'll take ownership nonetheless.

Thanks, I'd be all for hiding the preview in case of the BIOS clock being set to local time.

comment:6 Changed 8 years ago by Disreali

Any progress?

comment:7 Changed 8 years ago by leavengood

Resolution: fixed
Status: in-progressclosed

Fixed in hrev42990.

comment:8 Changed 8 years ago by Disreali

I would not concider hiding the feature a proper fix, but as I have no knowledge of how other systems deal with the situation, I really can't complain that much.

comment:9 Changed 8 years ago by leavengood

I suspect other systems don't have this time preview, or don't really allow for setting local time versus GMT time for the BIOS clock. The only reason we have this setting is to deal with multi boot systems where the other system could be Windows (which uses local time) or Linux (and most other systems) which use GMT time. Supposedly GMT time is better and there is even a website for complaining about how Windows is broken for using local time (which I can't find right now.) Part of the problem is using local time makes dealing with daylight saving harder, since the hardware clock has to be changed instead of just changing the time zone offset.

Anyhow back to the topic of this ticket: we've established that when using local time the preview is useless, yet the user still does need to choose a time zone, so hiding the preview is the best solution. I'm open to a better solution if it exists.

comment:10 Changed 8 years ago by Disreali

Thank you for a more detailed explanation if the issue. Sorry if I was rude and noisy.

comment:11 Changed 8 years ago by leavengood

It's fine, I'm always open to suggestions for improvement when fixing bugs, but I don't think this one has a better solution.

Note: See TracTickets for help on using tickets.