Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#6758 closed bug (fixed)

Date-columns overwriting column borders

Reported by: humdinger Owned by: zooey
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc: zooey
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev39138.

Date columns like "Modified" or "Created" or email's "When" are redrawn over their column borders. For example, open a Tracker window with Name, Size, Modified columns.
Name - Size - Modified Now move the Size column to the right of Modified.
Name - Modified - Size

hrev39123 may be the culprit.

Attachments (2)

screenshot1.png (33.2 KB) - added by humdinger 9 years ago.
Name - Size - Modified
screenshot2.png (35.3 KB) - added by humdinger 9 years ago.
Name - Modified - Size

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by humdinger

Attachment: screenshot1.png added

Name - Size - Modified

Changed 9 years ago by humdinger

Attachment: screenshot2.png added

Name - Modified - Size

comment:1 Changed 8 years ago by myob

To comment on this, I can remember when the date format would "collapse" down from the verbose one shown to ever more compact versions as you narrowed a column, down to dd/mm/yy at the lowest width.

I found this bug by searching before I posted another; this doesn't appear to happen with any other column type in testing.

comment:2 Changed 8 years ago by aldeck

Cc: zooey added
Owner: changed from axeld to aldeck
Status: newin-progress

Yes, hrev39123 is the culprit. The semantics changed for BLocale::FormatDateTime used in WidgetAttributeText. It now returns a size_t, where it was a status_t before. Thus the check for "== B_OK" that fails even if everything is ok, it should now be ">= 0". Confirmed working here, though i wonder if the change in BLocale was really intended that way (cc'ing to zooey).

comment:3 Changed 8 years ago by zooey

Owner: changed from aldeck to zooey

Right, the change in hrev39123 was intended (consolidation of different methods returning status_t or ssize_t). However, I obviously failed to adjust all callers ...

comment:4 Changed 8 years ago by zooey

Resolution: fixed
Status: in-progressclosed

Fixed in hrev39649 (which additionally restores the original set of 6 date formats).

comment:5 Changed 8 years ago by humdinger

Thanks very much! The ugliness was quite annoying. :)

Note: See TracTickets for help on using tickets.