Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6768 closed bug (invalid)

Failed init_transport when printing

Reported by: humdinger Owned by: laplace
Priority: normal Milestone: R1
Component: Printing Version: R1/Development
Keywords: Gutenprint, Canon iP4300 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev39247, gcc4hybrid.

I connected a Canon iP4300 via USB, powered it on and added it in the Printer preferences using Gutenprint. When I try to print I get an alert saying "init_transport failed.". The syslog says:

KERN: runtime_loader: Cannot open file /boot/home/config/add-ons/Print/transport/USB Port: No such file or directory

After I created the folder /boot/home/config/add-ons/Print/transport/USB Port manually, it's an init_transport failure. The syslog now says:

KERN: runtime_loader: /boot/home/config/add-ons/Print/transport/USB Port: Troubles reading ELF header

Change History (5)

comment:1 Changed 9 years ago by laplace

You can ignore the syslog messages, as the printer driver tries to load the "USB Port" transport add-on from different places without checking if the file exists.

It would be interesting to see if there is any output from the print server.
To get that you have to start print_server in the Termial. Before you to that quit it with Process Controller. Then open the Terminal and switch into the servers folder.

cd /boot/system/servers

and start the print_server

./print_server

Now when you try to print depending on how far it gets there should be a output from the Gutenprint driver add-on. If possible please post it here.

As I wrote in the commit message error reporting is missing. It could likely be a configuration problem. Increasing the page margins might solve the problem.

comment:2 Changed 9 years ago by humdinger

Resolution: invalid
Status: newclosed

I killed print_server and restarted from Terminal. To be sure, I removed the printer in the Printer preferences and re-added it once more. Now I also get a submenu under "USB Port" that didn't show up the first time, showing my correctly identified printer.
And what do you know? It's printing! Though it's quite slow with a 3 second pause after every printed line. I only tried text from StyledEdit so far, but that works in b&w and colour. Funny: If you have some text selected, it's printed just like it's shown on the screen, inverted. That's WYSIWYG for you. :)

Anyway, the ticket is invalid, as it was a messed up setting up of the printer. Maybe adding a text in the "Add printer" dialog would help: "Make sure your printer is connected and powered on."

comment:3 in reply to:  2 ; Changed 9 years ago by laplace

Replying to humdinger:

I killed print_server and restarted from Terminal. To be sure, I removed the printer in the Printer preferences and re-added it once more. Now I also get a submenu under "USB Port" that didn't show up the first time, showing my correctly identified printer.

It is somewhat sad that the printers preflet did not get updated to avoid that confusion, when the connected printer detection was added to the transport add-on API.

And what do you know? It's printing! Though it's quite slow with a 3 second pause after every printed line. I only tried text from StyledEdit so far, but that works in b&w and colour.

It is good news that colors are not mixed!

Slow is bad though. What resolution did you choose?

Funny: If you have some text selected, it's printed just like it's shown on the screen, inverted. That's WYSIWYG for you. :)

Unfortunately the printing code in StyledEdit seems to be not well tested too.

comment:4 in reply to:  2 Changed 9 years ago by laplace

Replying to humdinger:

Maybe adding a text in the "Add printer" dialog would help: "Make sure your printer is connected and powered on."

The problem is fixed a little differently in hrev39258 and hrev39260.

comment:5 in reply to:  3 Changed 9 years ago by humdinger

Replying to laplace:

Slow is bad though. What resolution did you choose?

I left it on default 600x600dpi. I now changed to 300x300 and with that it's pretty fast! No pauses at all when printing text. Nevertheless, 600x600, while being nominally 4 times the resolution still appears unnaturally slow compared to 300x300.

Nice work, anyway! And thanks for the improvements in hrev39258 and hrev39260. A much better solution!

Note: See TracTickets for help on using tickets.