Opened 9 years ago

Closed 2 years ago

#6775 closed bug (fixed)

[PNGTranslator] can't open /system/documentation/diskusage/*.png images

Reported by: diver Owned by: leavengood
Priority: normal Milestone: Unscheduled
Component: Add-Ons/Translators/PNG Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description (last modified by mmadia)

This is hrev39274 - gcc4.

The error is: "Could not load image! Either the file or an image translator for it does not exist."

note: this occurs only on gcc4.

Attachments (2)

ShowImage.png (80.6 KB) - added by diver 9 years ago.
ShowImage-2472-debug-16-07-2017-09-48-52.report (32.6 KB) - added by diver 2 years ago.

Download all attachments as: .zip

Change History (31)

comment:1 Changed 9 years ago by axeld

Certainly works here. Any more info?

comment:2 Changed 9 years ago by diver

Summary: [ShowImage] can't open /system/documentatoion/diskusage/*.png images[ShowImage] can't open /system/documentation/diskusage/*.png images

comment:3 Changed 9 years ago by diver

Here is terminal output:

ShowImage /boot/system/documentation/diskusage/home.png
MessageImporter::Import() - error unflattening icon archive: Data is not a message
libpng error: [00][20][00][00]: invalid chunk type

comment:4 Changed 9 years ago by mmadia

Does a second version libpng* exist outside of /boot/system? Any oddities reported by checkfs?

Changed 9 years ago by diver

Attachment: ShowImage.png added

comment:5 Changed 9 years ago by diver

Nope, it's a freshly built image.

comment:6 Changed 9 years ago by axeld

Resolution: invalid
Status: newclosed

Looks like this file is corrupted on your drive. MD5 looks like this over here:

28f23b5988ca58f36e7fbe77bbcd64f4  /boot/system/documentation/diskusage/home.png

comment:7 Changed 9 years ago by diver

Something still isn't right.
After rm -rf trunk/docs/apps/diskusage and image rebuild ShowImage still can't open this images, but Web+ has no problems opening them.
MD5 looks like yours.

comment:8 Changed 9 years ago by diver

WonderBrush also opens them just fine.

comment:9 Changed 9 years ago by axeld

Well something must be wrong at your side, since it's working fine here. And since the error comes from libpng.so, not ShowImage, maybe it's somehow using a different libpng.so version? I am using hrev39379.

comment:10 Changed 9 years ago by humdinger

FYI, these are the md5 for the two libpng.so.1.4 on my system:

~> md5sum /boot/system/lib/gcc2/libpng.so.1.4
cd6ac6d0cc651eda8b0110d422184ed5  /boot/system/lib/gcc2/libpng.so.1.4
~> md5sum /boot/system/lib/libpng.so.1.4
7a123283c75968a5ec845a75818c6171  /boot/system/lib/libpng.so.1.4

I get the same error with these PNGs. MD5 is the same. Opening in WonderBrush works but says:

libpng error: PNG unsigned integer out of range

Image is hrev39402, gcc4hybrid.

Last edited 9 years ago by humdinger (previous) (diff)

comment:12 Changed 9 years ago by diver

comment:13 Changed 9 years ago by mmadia

Running the ShowImage binary from hrev39395-gcc4 inside hrev39385-gcc2hybrid exhibits the issue (comment:3) as well.

comment:14 Changed 9 years ago by axeld

Resolution: invalid
Status: closedreopened

Then it's at least sure there is indeed something wrong, it's just the question where.

comment:15 Changed 9 years ago by Ka

These two PNGs also do not work here (hrev39605) (edit: GCC4hybrid), but they are just destroyed. They cannot be opened at my normal OS, too.

Edit: Just discovered, that hrev39605 GCC2hybrid is able to show them. At my main System, Eye of Gnome can't display them, Gimp shows them correct.

Last edited 9 years ago by Ka (previous) (diff)

comment:16 Changed 9 years ago by stargatefan

still seeing trouble with jpegs only at 39943 gcc2 hybrid

comment:17 Changed 8 years ago by luroh

Still with us in nightly hrev40715, gcc4.

Replying to stargatefan:

still seeing trouble with jpegs only at 39943 gcc2 hybrid

Likely not related to this bug, please file a new ticket if the problem still exists.

comment:18 Changed 8 years ago by halilpk

(GCI-2011 Participant)

Haiku revision: hrev42211 not a bug. There are 4 libpng.so and 4 libpng.so.1.4 files in system or develop directories.And there is no problem with opening png files . System: Haiku hrev1-alpha3 on VMware workstation 8 on windows 7 32 bit

comment:19 Changed 8 years ago by humdinger

Resolution: fixed
Status: reopenedclosed

ShowImage shows those PNGs, though still showing "libpng error: PNG unsigned integer out of range". Closing as fixed anyway. (As aside: I don't see a reason to keep /boot/system/documentation/diskusage at all...)

comment:20 Changed 8 years ago by diver

This is gcc4 only issue which is still here. I think it should be reopened.

comment:21 Changed 8 years ago by humdinger

Resolution: fixed
Status: closedreopened

Ah, didn't know that... reopened then.

comment:22 Changed 7 years ago by mmadia

Description: modified (diff)

comment:23 Changed 7 years ago by diver

Component: Applications/ShowImageAdd-Ons/Translators/PNG
Summary: [ShowImage] can't open /system/documentation/diskusage/*.png images[PNGTranslator] can't open /system/documentation/diskusage/*.png images

Still with us in hrev44676.

comment:24 Changed 5 years ago by pulkomandy

Milestone: R1Unscheduled

gcc4-only, moving out of R1.

comment:25 Changed 2 years ago by diver

Interestingly, on x86_64 these images crash ShowImage.

comment:26 Changed 2 years ago by diver

Has a Patch: set

comment:27 Changed 2 years ago by pulkomandy

Can't we just run these images through pngcrush or optipng to re-encode them? I think that would fix the issue. Unless we can find other images elsewhere triggering the same problem.

comment:28 Changed 2 years ago by diver

That might be an option, yes. However Web+ and Qt apps have no problem opening those.

comment:29 Changed 2 years ago by pulkomandy

Resolution: fixed
Status: reopenedclosed

Fixed in hrev51297:

  • Fixed the crash in ShowImage. Failing to open files is ok, crashing is not.
  • Replaced the images with modern and hopefully correct PNGs.
Note: See TracTickets for help on using tickets.