Opened 9 years ago

Closed 4 years ago

#6783 closed bug (fixed)

[DriveSetup] Partition->Mount All option doesn't always work

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/DriveSetup Version: R1/Development
Keywords: gci2014 Cc: mdisreali@…
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description


Attachments (1)

0001-DriveSetup-Also-mount-BDiskDevices-which-contain-a-f.patch (701 bytes) - added by puckipedia 4 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 9 years ago by Disreali

Cc: mdisreali@… added

What revision?

comment:2 Changed 9 years ago by diver

Sorry, it's hrev39274.

comment:3 Changed 9 years ago by stargatefan

works fine on the gcc4 hybrid hrev39274 ??? maybe its a problem with one of the drives. what are the drive file formats you are attempting to mount ?

IE NTFS,FAT32,EXT ? BFS ?

I have had problems with mounting NTFS under windows 7 64 bit.

comment:4 Changed 9 years ago by diver

It's BFS partition which mounts/unmounts ok using DriveSetup, but won't mount using "Mount all" option or Alt+Shift+M. Trying to do that in Terminal doesn't print anything.

comment:5 Changed 8 years ago by stippi

Resolution: fixed
Status: newclosed

Fixed in hrev39891. It definitely works. If individual partitions fail to mount, it's a different problem. In some circumstances, all your unmounted partitions may fail to mount for another problem, but this function in DriveSetup works as intended.

comment:6 Changed 8 years ago by diver

Resolution: fixed
Status: closedreopened

The problem still exists for me in hrev39894.

  • I unmounted my /data (bfs) partition
  • Used Partition->Mount All to mount it back.

comment:7 Changed 8 years ago by stippi

I tested exactly such a scenario multiple times and with different combinations of partitions being unmounted, via Tracker and via DriveSetup itself. What happens if you try to mount just that partition? In any case I need more information. If have one NTFS partition which mounted once in DriveSetup (Mount all feature) and then not anymore in subsequent tries, while other partitions (BFS and ReiserFS) mounted fine. Trying to mount the NTFS partition individually gave me a "Permission denied" error (WTF?!). The "Mount all" feature as such works like intended.

comment:8 Changed 8 years ago by diver

Mounting and unmounting of that partition works both from Tracker and DriveSetup. I even tested with default locale - same thing.

comment:9 Changed 8 years ago by stippi

Do you have more than one drive perhaps?

comment:10 Changed 8 years ago by diver

Nope, it's a 2Gb virtual drive (.vdi image) connected in VirtualBox.

comment:11 Changed 8 years ago by diver

Summary: [DriveSetup] Partition->Mount All option doesn't work[DriveSetup] Partition->Mount All option doesn't always work

comment:12 Changed 8 years ago by Disreali

Not experienced on hrev40859-4h on real hw. This may just be a issue with VirtualBox.

comment:13 Changed 8 years ago by diver

Yep, maybe I can turn on debug output somewhere to help nailing it down? Stippi?

comment:14 Changed 6 years ago by diver

Still present in hrev45853.

comment:15 Changed 5 years ago by diver

Still present in hrev47897.

comment:16 Changed 4 years ago by puckipedia

Has a Patch: set

comment:17 Changed 4 years ago by puckipedia

Okay, I think I found the culprit (for Google Code-in task http://www.google-melange.com/gci/task/view/google/gci2014/6337204683014144). Adding a patch which fixed the problem for me: Mount All doesn't mount file systems directly on the disk itself, only as a partition. Patch has been added.

comment:18 Changed 4 years ago by stippi

Thanks! Patch looks good to me. I may not have the time to apply in the near future, so if someone beats me to it, I'd be grateful.

comment:19 Changed 4 years ago by diver

I've just tested the patch and it fixes the problem for me. Thanks! :)

comment:20 Changed 4 years ago by pulkomandy

Keywords: gci2014 added
Resolution: fixed
Status: reopenedclosed

Applied in hrev48473.

Note: See TracTickets for help on using tickets.