Opened 9 years ago

Closed 9 years ago

#6804 closed bug (fixed)

crash: chart demo application crashes (reproducible)

Reported by: kallisti5 Owned by: nobody
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: chart Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  • VESA driver.
  • Multi-core or multi-cpu system (two core AMD in my case)
  • hrev39317 gcc4 hybrid

To Reproduce:

  • disable CPU core 1
  • launch chart
  • enable "2 threads"
  • fast motion
  • direct window
  • space == chaos
  • enable CPU core 1
  • move mouse in window / click
  • GDB

First time:

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 633 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libgame.so...done.
Loaded symbols for /boot/system/lib/libgame.so
Reading symbols from /boot/system/lib/libsupc++.so...done.
Loaded symbols for /boot/system/lib/libsupc++.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libstdc++.so...done.
Loaded symbols for /boot/system/lib/libstdc++.so
Reading symbols from /boot/system/lib/libmedia.so...done.
Loaded symbols for /boot/system/lib/libmedia.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/demos/Chart (627) thread chart animation2 (633)]
0x00208005 in RefreshStarPacket ()
(gdb) bt
#0  0x00208005 in RefreshStarPacket ()
#1  0x0020b9f1 in ChartWindow::Animation2 ()
#2  0x004cf91c in thread_entry () from /boot/system/lib/libroot.so
#3  0x700c1fec in ?? ()
(gdb) 

Second time:

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 3645 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libgame.so...done.
Loaded symbols for /boot/system/lib/libgame.so
Reading symbols from /boot/system/lib/libsupc++.so...done.
Loaded symbols for /boot/system/lib/libsupc++.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libstdc++.so...done.
Loaded symbols for /boot/system/lib/libstdc++.so
Reading symbols from /boot/system/lib/libmedia.so...done.
Loaded symbols for /boot/system/lib/libmedia.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/demos/Chart (3639) thread chart animation2 (3645)]
0x00207f98 in EraseStar ()
(gdb) bt
#0  0x00207f98 in EraseStar ()
#1  0x0020801a in RefreshStarPacket ()
#2  0x0020b9f1 in ChartWindow::Animation2 ()
#3  0x004cf91c in thread_entry () from /boot/system/lib/libroot.so
#4  0x700c1fec in ?? ()
(gdb) 

Change History (5)

comment:1 by kallisti5, 9 years ago

Summary: crash: chart demo application crashes (reproduceable)crash: chart demo application crashes (reproducible)

comment:2 by humdinger, 9 years ago

FWIW, following your instructions, I can't reproduce with a Core2Duo on hrev39308 gcc4hybrid.

comment:3 by MichaelPeppers, 9 years ago

Not reproducible here in hrev39053 gcc4hybrid with an Athlon II x2 250 (VESA driver, of course). Will test with a newer nightly.

Last edited 9 years ago by MichaelPeppers (previous) (diff)

comment:4 by MichaelPeppers, 9 years ago

Can't reproduce in hrev39551 either, same specs as last post.

comment:5 by humdinger, 9 years ago

Resolution: fixed
Status: newclosed

Seems to be fixed then. Closing ticket. Thanks!

Note: See TracTickets for help on using tickets.