Opened 10 years ago

Closed 7 years ago

#6815 closed bug (fixed)

web positive close on a certain page

Reported by: AlienSoldier Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86

Description

ver: 545 haiku build: 39360 site: www.gizmag.com behavior: Webpositive close and disappear without giving an error when scrolling down on that page. I think once i saw something like: can't allocate bitmap or memory off screen, but i did not bother to write it so i don't remember it correctly and never saw it again. Current problem can be replicated at will here (i have no other example of another page doing this so far).

Change History (5)

comment:1 by humdinger, 10 years ago

FWIW, it's working here with hrev39402. Maybe checkfs or renaming cache files in ~/config/settings/WebPositive/ one by one can help? Interesting site BTW.

comment:2 by AlienSoldier, 10 years ago

I tested it again. I always have 17 or bust on to stress test the system and it closed again. I disabled it to see if it was related to high cpu usage. I was able to scroll without a crash this time. Tested again with 17 or bust re enabled, no crash. Now i can't seem to be able to crash it again. Could it be a corruption of the site cache that is now overwritten? In any case i can't replicate it anymore so i will consider the ticket solved for now.

comment:3 by stippi, 10 years ago

The ticket should not be considered solved. Perhaps the exit was triggered by a certain image that is no longer on the front page? An unexpected exit could be due to an unjustified abort() in the code, or an uncaught exception, although Haiku may show a default alert for uncaught exceptions (at least BeOS used to). In any case I have no time to look into this, sorry.

comment:4 by stippi, 10 years ago

Darn, I forgot to mention that there is no such thing as a page cache in WebPositive. It loads everything off the net at all times. There is only a cookie and credential storage and application settings.

comment:5 by pulkomandy, 7 years ago

Resolution: fixed
Status: newclosed

I'm going to close this ticket anyway, no news for 3 years and there were a lot of changes in the WebKit code since then. Since this is not reproductible, and there's no debug report, the ticket isn't very useful anyway.

Note: See TracTickets for help on using tickets.