Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6853 closed bug (fixed)

[FileTypes] "Invalid argument" error while creating new filetype with space in internal name

Reported by: diver Owned by: phoudoin
Priority: normal Milestone: R1
Component: Preferences/FileTypes Version: R1/Development
Keywords: Cc:
Blocked By: #6885 Blocking:
Has a Patch: no Platform: All

Description

This is hrev39554 gcc4hybrid.

Attachments (1)

FileTypes.png (30.4 KB ) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (11)

by diver, 9 years ago

Attachment: FileTypes.png added

comment:1 by phoudoin, 9 years ago

Resolution: invalid
Status: newclosed

As MIME/internet media type syntax don't allow space either in type/subtype, it's not a bug but an actual valid user alert.

Maybe the field name should be more obvious than group & internal, though.

comment:2 by diver, 9 years ago

It's not clear from error description why it failed.

comment:3 by phoudoin, 9 years ago

Resolution: invalid
Status: closedreopened

Reopened, because indeed it must be more clear or simply such error should be avoid to happen.

comment:4 by phoudoin, 9 years ago

Owner: changed from axeld to phoudoin
Status: reopenedin-progress

comment:5 by phoudoin, 9 years ago

Fixed in hrev39556, by filter-out space at input.

comment:6 by phoudoin, 9 years ago

Resolution: fixed
Status: in-progressclosed

comment:7 by diver, 9 years ago

BTW, it's still possible to paste space or any other disallowed characters into this field.

comment:8 by stippi, 9 years ago

IIRC, BeOS BTextView implementation did filter pasted or dropped text according to the disallowed chars.

comment:9 by axeld, 9 years ago

Even if it doesn't do that, that would certainly make sense - even not allowing to paste at all would make more sense than ignoring the disallowed characters completely.

comment:10 by phoudoin, 9 years ago

Blocked By: 6885 added
Note: See TracTickets for help on using tickets.