Opened 9 years ago

Closed 9 years ago

#6906 closed bug (fixed)

[CPUFrequency] window is huge

Reported by: diver Owned by: czeidler
Priority: normal Milestone: R1
Component: Preferences/CPUFrequency Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev39614 gcc4hybrid.

This is now:



Mockup:

Attachments (3)

CPUFrequency_mockup.png (18.9 KB ) - added by diver 9 years ago.
CPUFrequency.png (21.7 KB ) - added by diver 9 years ago.
CPUFreq.png (19.6 KB ) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (13)

by diver, 9 years ago

Attachment: CPUFrequency_mockup.png added

by diver, 9 years ago

Attachment: CPUFrequency.png added

comment:1 by diver, 9 years ago

So the only thing I did is to remove Stepping policy: label.
Popup menu can also be replaced with radio buttons.

comment:2 by czeidler, 9 years ago

Resolution: fixed
Status: newclosed

Think radio buttons are a bad idea because there could be arbitrary number of cpu states.

by diver, 9 years ago

Attachment: CPUFreq.png added

comment:3 by diver, 9 years ago

Thanks, it's much better now! There is still some room for improvements, though.

This is now:


Mockup:

comment:4 by czeidler, 9 years ago

It seems that you already fixed it could you supply a patch?

comment:5 by diver, 9 years ago

Nope :-) It's a mockup.

comment:6 by czeidler, 9 years ago

Ok think there is some more work to do with the slider-color-view, since the driver is not working for me it is not that easy to fix. I propose to wait with this fix till somebody wrote a ACPI speedstep driver.

comment:7 by diver, 9 years ago

Resolution: fixed
Status: closedreopened

Slider-color-view? I can't see anything on the screenshot. I thought that it shoul be more or less a simple gui fix regarding window size.

comment:8 by czeidler, 9 years ago

Yes its because the driver is not working. With the driver there is a color bar between slider and the 2 "?MHz" labels. The problem is that this slider-colorbar-view is not layout aware and need some more work...

comment:9 by diver, 9 years ago

I see, thanks.

comment:10 by czeidler, 9 years ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.