Opened 8 years ago

Closed 4 years ago

#6934 closed bug (fixed)

Text Alignment Bugs When Font Size 12 or 18

Reported by: kwinn29 Owned by: yourpalal
Priority: normal Milestone: R1
Component: User Interface Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Attached are screenshots of text alignment bugs. Here is a list of the places there were bugs:

Clock

  • Main, when font size 18

Clock, Main, when font size 18

Magnify

  • Main, when font size 18

Magnify, Main, when font size 18

Attachments (28)

BePDF-AboutBePDF-18.png (107.5 KB) - added by kwinn29 8 years ago.
BePDF, About BePDF, when font size 18
BePDF-Preferences-Display-18.png (33.4 KB) - added by kwinn29 8 years ago.
BePDF, Preferences, Display, when font size 18
BePDF-Preferences-Document-18.png (28.9 KB) - added by kwinn29 8 years ago.
BePDF, Preferences, Document, when font size 18
Chart-12.png (27.4 KB) - added by kwinn29 8 years ago.
Chart, Main, when font size 12
Chart-18.png (36.6 KB) - added by kwinn29 8 years ago.
Chart, Main, when font size 18
Clock-18.png (8.7 KB) - added by kwinn29 8 years ago.
Clock, Main, when font size 18
Expander-Settings-18.png (37.0 KB) - added by kwinn29 8 years ago.
Expander, Settings, when font size 18
FontDemo-Controls-12.png (15.4 KB) - added by kwinn29 8 years ago.
FontDemo, Controls, when font size 12
FontDemo-Controls-18.png (22.5 KB) - added by kwinn29 8 years ago.
FontDemo, Controls, when font size 18
Magnify-Dropdown-18.png (18.4 KB) - added by kwinn29 8 years ago.
Magnify, Main, when font size 18
Magnify-Help-12.png (23.8 KB) - added by kwinn29 8 years ago.
Magnify, Help, when font size 12
Magnify-Help-18.png (26.0 KB) - added by kwinn29 8 years ago.
Magnify, Help, when font size 18
Mail-E-mail-Account-18.png (36.3 KB) - added by kwinn29 8 years ago.
Mail, E-mail, Account when font size 18
Mail-E-mail-Settings-18.png (35.2 KB) - added by kwinn29 8 years ago.
Mail, E-mail, Settings, when font size 18
MediaConverter-18.png (44.0 KB) - added by kwinn29 8 years ago.
MediaConverter, Main, when font size 18
Pe-File Options-Editor-12.png (25.9 KB) - added by kwinn29 8 years ago.
Pe, File Options, Editor, when font size 12
Pe-File Options-Editor-18.png (41.7 KB) - added by kwinn29 8 years ago.
Pe, File Options, Editor, when font size 18
Vision-12.png (28.7 KB) - added by kwinn29 8 years ago.
Vision, Main, when font size 12
Vision-18.png (32.4 KB) - added by kwinn29 8 years ago.
Vision, Main, when font size 18
Vision-Network Setup-18.png (35.7 KB) - added by kwinn29 8 years ago.
Vision, Network Setup, when font size 18
Vision-Preferences-Aliases-18.png (25.6 KB) - added by kwinn29 8 years ago.
Vision, Preferences, Aliases, when font size 18
Vision-Preferences-Application-18.png (38.6 KB) - added by kwinn29 8 years ago.
Vision, Preferences, Application, when font size 18
Vision-Preferences-Commands-18.png (34.2 KB) - added by kwinn29 8 years ago.
Vision, Preferences, Commands, when font size 18
Vision-Preferences-DCC-18.png (35.3 KB) - added by kwinn29 8 years ago.
Vison, Preferences, DCC, when font size 18
Vision-Preferences-Events-18.png (37.3 KB) - added by kwinn29 8 years ago.
Vision, Preferences, Events, when font size 18
Vision-Preferences-Fonts-12.png (15.6 KB) - added by kwinn29 8 years ago.
Vision, Preferences, Fonts, when font size 12
Vision-Preferences-Fonts-18.png (26.3 KB) - added by kwinn29 8 years ago.
Vision, Preferences, Fonts, when font size 18
Vision-Preferences-Logging-18.png (32.3 KB) - added by kwinn29 8 years ago.
Vision, Preferences, Logging, when font size 18

Download all attachments as: .zip

Change History (37)

Changed 8 years ago by kwinn29

Attachment: BePDF-AboutBePDF-18.png added

BePDF, About BePDF, when font size 18

Changed 8 years ago by kwinn29

BePDF, Preferences, Display, when font size 18

Changed 8 years ago by kwinn29

BePDF, Preferences, Document, when font size 18

comment:1 Changed 8 years ago by kwinn29

Has a Patch: set

Changed 8 years ago by kwinn29

Attachment: Chart-12.png added

Chart, Main, when font size 12

Changed 8 years ago by kwinn29

Attachment: Chart-18.png added

Chart, Main, when font size 18

Changed 8 years ago by kwinn29

Attachment: Clock-18.png added

Clock, Main, when font size 18

Changed 8 years ago by kwinn29

Attachment: Expander-Settings-18.png added

Expander, Settings, when font size 18

Changed 8 years ago by kwinn29

Attachment: FontDemo-Controls-12.png added

FontDemo, Controls, when font size 12

Changed 8 years ago by kwinn29

Attachment: FontDemo-Controls-18.png added

FontDemo, Controls, when font size 18

Changed 8 years ago by kwinn29

Attachment: Magnify-Dropdown-18.png added

Magnify, Main, when font size 18

Changed 8 years ago by kwinn29

Attachment: Magnify-Help-12.png added

Magnify, Help, when font size 12

Changed 8 years ago by kwinn29

Attachment: Magnify-Help-18.png added

Magnify, Help, when font size 18

Changed 8 years ago by kwinn29

Attachment: Mail-E-mail-Account-18.png added

Mail, E-mail, Account when font size 18

Changed 8 years ago by kwinn29

Attachment: Mail-E-mail-Settings-18.png added

Mail, E-mail, Settings, when font size 18

Changed 8 years ago by kwinn29

Attachment: MediaConverter-18.png added

MediaConverter, Main, when font size 18

Changed 8 years ago by kwinn29

Pe, File Options, Editor, when font size 12

Changed 8 years ago by kwinn29

Pe, File Options, Editor, when font size 18

Changed 8 years ago by kwinn29

Attachment: Vision-12.png added

Vision, Main, when font size 12

Changed 8 years ago by kwinn29

Attachment: Vision-18.png added

Vision, Main, when font size 18

Changed 8 years ago by kwinn29

Attachment: Vision-Network Setup-18.png added

Vision, Network Setup, when font size 18

Changed 8 years ago by kwinn29

Vision, Preferences, Aliases, when font size 18

Changed 8 years ago by kwinn29

Vision, Preferences, Application, when font size 18

Changed 8 years ago by kwinn29

Vision, Preferences, Commands, when font size 18

Changed 8 years ago by kwinn29

Vison, Preferences, DCC, when font size 18

Changed 8 years ago by kwinn29

Vision, Preferences, Events, when font size 18

Changed 8 years ago by kwinn29

Vision, Preferences, Fonts, when font size 12

Changed 8 years ago by kwinn29

Vision, Preferences, Fonts, when font size 18

Changed 8 years ago by kwinn29

Vision, Preferences, Logging, when font size 18

comment:2 Changed 8 years ago by yourpalal

Owner: changed from stippi to yourpalal
Status: newassigned

comment:3 Changed 8 years ago by anevilyak

@yourpalal: the Vision ones will be dealt with eventually, in the middle of a rewrite to make that locale/layout aware at the moment.

comment:4 Changed 8 years ago by kwinn29

Version: R1/alpha2

comment:5 Changed 8 years ago by kwinn29

Edit:

Chart, Main, when font size 18 and 12 has been fixed since alpha 2

MediaConverter, Main, when font size 18 has been resolved

BePDF, About BePDF, when font size 18 clarification: The issue is that when you open About BePDF when the font size is 18, the window opens so that it is above the top of the screen, so you cannot move the window (at least that is what happened to me).

Magnify, Dropdown, when font size 18 clarification: The issue is that the dropdown overlaps the text when the font size is 18. This doesn't happen when the font size is 12. You can see in the screenshot, it overlaps "a)".

comment:6 Changed 7 years ago by Charlie_X

Has a Patch: unset

comment:7 Changed 4 years ago by pulkomandy

Description: modified (diff)

Removing outdated items from description (FontDemo was fixed in hrev48396).

comment:8 Changed 4 years ago by diver

Description: modified (diff)
Version: R1/alpha2R1/Development

comment:9 Changed 4 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed

Fixed magnify in hrev48445. Closing the ticket as there is nothing much to do about Clock, the current behavior seems correct to me.

Note: See TracTickets for help on using tickets.