Opened 8 years ago

Closed 8 years ago

#6995 closed bug (invalid)

svn: Checksum mismatch while updating 'docs/userguide/zh_CN/preferences/*.html'

Reported by: Karvjorm Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: svn update checksum mismatch Cc: Karvjorm
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Some .html files in preferences directory are showing checksum mismatch.

Attachments (2)

checksummismatch.png (31.2 KB) - added by Karvjorm 8 years ago.
Checksum mismatch is still there when testing in hrev40043
checksummismatch2.png (9.9 KB) - added by Karvjorm 8 years ago.
Another svn update test after checkfs -c /Blank_BFS/

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by Karvjorm

Attachment: checksummismatch.png added

Checksum mismatch is still there when testing in hrev40043

comment:1 Changed 8 years ago by diver

Version: R1/alpha2R1/Development

Try to check your file system with checkfs -c /Blank_BFS

comment:2 Changed 8 years ago by siarzhuk

Workaround: Completely remove the zh_CN/preferences subfolder and run "svn up" to resore clean copy.

Changed 8 years ago by Karvjorm

Attachment: checksummismatch2.png added

Another svn update test after checkfs -c /Blank_BFS/

comment:3 Changed 8 years ago by Karvjorm

I tried first that checkfs -c /Blank_BFS/ and it showed:

117554 nodes checked,
0 blocks not allocated,
0 blocks already set,
4 blocks could be freed

files       89759
directories 27621
attributes  98
attr. dirs  55
indices     21

But it did not helped as can be shown in the following figure:

https://dev.haiku-os.org/attachment/ticket/6995/checksummismatch2.png

But when I deleted the whole preferences directory, svn up succeeded. I had previously tried to delete mismatched files and then tried to svn update without success. Thanks. This is now fixed.

Last edited 8 years ago by Karvjorm (previous) (diff)

comment:4 in reply to:  3 Changed 8 years ago by siarzhuk

Replying to Karvjorm:

But when I deleted the whole preferences directory, svn up succeeded. I had previously tried to delete mismatched files and then tried to svn update without success. Thanks. This is now fixed.

I suspect that incorrect checksum was stored inside of preferences/.svn/ special files. May it be a SVN issue or corrupted BFS result? I have no idea.

comment:5 Changed 8 years ago by axeld

Resolution: invalid
Status: newclosed

I had those problems under Linux as well with SVN. While we cannot be entirely sure that the error has been caused by a file system issue, I would consider it a SVN bug which makes this invalid here.

Note: See TracTickets for help on using tickets.