Opened 9 years ago

Closed 5 years ago

#7012 closed bug (fixed)

[SoundRecorder] crashes in RawDecoder::Decode ()

Reported by: diver Owned by: korli
Priority: normal Milestone: R1
Component: Applications/SoundRecorder Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev39914, gcc4hybrid.

  • Record a short clip
  • Expand main window
  • Select and deselect "Audio Clip 1" a few times
    Thread 2157 caused an exception: Segment violation
    [...]
    [Switching to team /boot/system/apps/SoundRecorder (2148) thread Scope view (2157)]
    0x02a10b02 in RawDecoder::Decode ()
       from /boot/system/add-ons/media/plugins/raw_decoder
    (gdb) bt
    #0  0x02a10b02 in RawDecoder::Decode ()
       from /boot/system/add-ons/media/plugins/raw_decoder
    #1  0x00520b79 in BMediaTrack::ReadFrames () from /boot/system/lib/libmedia.so
    #2  0x00520c88 in BMediaTrack::ReadFrames () from /boot/system/lib/libmedia.so
    #3  0x0021cdb9 in ScopeView::ComputeRendering<short, long long> ()
    #4  0x0021bd9b in ScopeView::RenderLoop ()
    #5  0x0021be41 in ScopeView::RenderLaunch ()
    #6  0x007fe044 in thread_entry () from /boot/system/lib/libroot.so
    #7  0x70102fec in ?? ()
    (gdb)
    

Change History (1)

comment:1 Changed 5 years ago by diver

Resolution: fixed
Status: newclosed

Can't reproduce anymore.

Note: See TracTickets for help on using tickets.