Opened 9 years ago

Closed 5 months ago

#7016 closed bug (duplicate)

Garbage at bottom of the screen

Reported by: mr.Noisy Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: intel_extreme GMA965 garbage 1920x1080 32bit Cc:
Blocked By: #3484 Blocking:
Has a Patch: no Platform: x86

Description

Hello! My Intel GMA965 (PCI/VEN: 8086:29a2) produces garbage (see photo) at bottom of the screen at 1920x1080x32 resolution. With other resolutions and/or bit depths the problem is absent.

Attachments (3)

DSC09999.JPG (38.5 KB ) - added by mr.Noisy 9 years ago.
screenshot5.png (21.6 KB ) - added by mr.Noisy 9 years ago.
screenshot6.png (83.8 KB ) - added by mr.Noisy 9 years ago.

Download all attachments as: .zip

Change History (15)

by mr.Noisy, 9 years ago

Attachment: DSC09999.JPG added

comment:1 by mr.Noisy, 9 years ago

Keywords: intel_extreme GMA965 garbage 1920x1080 32bit added

comment:2 by axeld, 9 years ago

I'm not sure if a screenshot is made from the back or front buffer, but is the garbage visible on a screenshot as well?

comment:3 by mr.Noisy, 9 years ago

Yes, screenshot looks similarly.

by mr.Noisy, 9 years ago

Attachment: screenshot5.png added

comment:4 by axeld, 9 years ago

That's very helpful, thanks! Apparently, your BIOS reserves 8 MB of memory which this resolution manages to exhaust (because of some other buffers for 2D acceleration, and the mouse cursor). It looks like my AGP implementation fails reserving memory outside of this region.

If you are able to switch to a 1 MB video buffer in the BIOS, the problem should get much worse - if you are able to select a higher amount of memory, the problem should go away. In either case, I can try to reproduce this on my i965 in the next few weeks.

comment:5 by axeld, 9 years ago

That reminds me: can you provide a syslog as well?

comment:6 by mr.Noisy, 9 years ago

comment:7 by mr.Noisy, 9 years ago

You were right about 1MB video buffer - it is worst result. Sorry, BIOS of my motherboard do not able to set buffer higher than 8 MB - so I can't check your suggestion.

by mr.Noisy, 9 years ago

Attachment: screenshot6.png added

comment:8 by leavengood, 8 years ago

I have the same issue when using my 910GL onboard video. I will try increasing the BIOS memory to see what happens.

comment:9 by leavengood, 8 years ago

I too cannot go above an 8MB buffer size. Guess on-board video just isn't meant to go to 1080p resolutions. Guess I have to go back to my old Nvidia card which produces major streaking.

Edit: changing to 16 bit color at least stops the garbage problem with the on-board video. Not perfect but enough for my development.

Last edited 8 years ago by leavengood (previous) (diff)

comment:10 by axeld, 8 years ago

FWIW the solution for the Intel driver has been developed with a G3 and a i965 based chipset -- both of which do support more than just 8 MB frame buffer (tested with overlays), although I have not tested with a higher resolution than 1680x1050 for lack of hardware.

comment:11 by axeld, 2 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:12 by waddlesplash, 5 months ago

Blocked By: 3484 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.