Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7018 closed bug (fixed)

Mounting an ext3 partition

Reported by: eu Owned by: korli
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: ext3, panic Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I tested various versions of the 39924 nightly build on a Lenovo T61p laptop.

When mounting read-only an ext4 or ext3 partition with any gcc4 or gcc4 hybrid build I get a kernel panic. Trying the same thing with a gcc2 or gcc2 hybrid build works just fine.

Attachments (2)

P1010001.JPG (235.0 KB) - added by eu 9 years ago.
DriveSetup showing existing partitions
P1010002.JPG (486.2 KB) - added by eu 9 years ago.
Panic !!!

Download all attachments as: .zip

Change History (17)

comment:1 Changed 9 years ago by diver

Is it recognized in DriveSetup? My ext4 partition is not. Should I open a ticket for that korli?

comment:2 Changed 9 years ago by eu

It is recognized in DriveSetup, but it is an ext3 partition. Sorry, I should not have included the ext4 partition in my report, because that one is not recognized in DriveSetup.

comment:3 Changed 9 years ago by diver

Bummer :( Anyway if possible please include a photo of the kernel panic.

comment:4 in reply to:  3 Changed 9 years ago by eu

I'll try to do that in the next hour or so.

Changed 9 years ago by eu

Attachment: P1010001.JPG added

DriveSetup showing existing partitions

Changed 9 years ago by eu

Attachment: P1010002.JPG added

Panic !!!

comment:5 in reply to:  3 Changed 9 years ago by eu

diver, I attached 2 photos.

comment:6 Changed 9 years ago by eu

Keywords: ext4 removed
Platform: Allx86
Summary: Mounting an ext4/ext3 partitionMounting an ext3 partition

comment:7 Changed 9 years ago by bonefish

Owner: changed from axeld to korli
Status: newassigned

comment:8 Changed 9 years ago by korli

Component: File Systems/ext2System/Kernel

the ext2 addon provides its own DirectoryIterator, though the stack trace seems to imply the addon uses the DirectoryIterator provided by the kernel. It looks like a problem with the elf symbol resolution. Reassigning to kernel. Ingo maybe has an idea.

comment:9 in reply to:  1 ; Changed 9 years ago by korli

Replying to diver:

Is it recognized in DriveSetup? My ext4 partition is not. Should I open a ticket for that korli?

It's probably normal as we still miss a few features. Don't hold your breath, but they should be included by the end of January.

comment:10 in reply to:  8 Changed 9 years ago by bonefish

Replying to korli:

the ext2 addon provides its own DirectoryIterator, though the stack trace seems to imply the addon uses the DirectoryIterator provided by the kernel.

Ah, indeed, I missed that. All kernel classes (at least all with virtual methods) should live in an appropriate namespace (the unnamed namespace for classes only used within a source file or BPrivate or B* for others) to avoid clashes with equally named classes in add-ons. In this case the problem is the DirectoryIterator class in device_manager/legacy_drivers.cpp.

comment:11 Changed 9 years ago by korli

I added a LegacyDrivers namespace for legacy_drivers.cpp in hrev39945.

comment:12 in reply to:  11 Changed 9 years ago by eu

Replying to korli:

I added a LegacyDrivers namespace for legacy_drivers.cpp in hrev39945.

I built hrev39952 as gcc4hybrid and was able to mount the ext3 partition. It seems that the problem is fixed.

comment:13 Changed 9 years ago by korli

Resolution: fixed
Status: assignedclosed

Thanks for the feedback.

comment:14 in reply to:  9 ; Changed 9 years ago by diver

Replying to korli:

It's probably normal as we still miss a few features. Don't hold your breath, but they should be included by the end of January.

Awesome! I can mount my ext4 partition since hrev40129. Thank you very much!

comment:15 in reply to:  14 Changed 9 years ago by korli

Replying to diver:

Replying to korli:

It's probably normal as we still miss a few features. Don't hold your breath, but they should be included by the end of January.

Awesome! I can mount my ext4 partition since hrev40129. Thank you very much!

You're welcome. Please test a bit, just be warned that data corruption is possible when mounting read/write.

Note: See TracTickets for help on using tickets.