Opened 9 years ago

Closed 9 years ago

#7020 closed bug (duplicate)

Multi-session handling for CDs rather poor/flaky

Reported by: myob Owned by: nobody
Priority: normal Milestone: R1
Component: File Systems/ISO 9660 Version: R1/alpha2
Keywords: CD iso9660 Cc:
Blocked By: #3473 Blocking:
Has a Patch: no Platform: All

Description

Note: I noticed this with the modified iso9660 addon that Axel distributed for R5 in the early 2000s and I'm assuming this is what Haiku is using

Some multi-session CDs are handled very poorly, with only some of the sessions appearing.

For example, a recent "CD+" enhanced CD ("On A Good Day (Metropolis) by Above & Beyond) has only the CDDA part of the disc mounted as the virtual CDDA file system. The ISO section (containing mov files) isn't given as an option. Other enhanced CDs have worked in the past.

Something with a slightly higher chance of someone else having it; the CD for Corum III for BeOS consists of an ISO session, a little endian BFS session and a big endian BFS session. The game data is on the ISO session with the binaries being on the endian specific ones. The ISO session is never mountable so you can't install it.

If you've got an affected disc it seems 100% reproducable.

Change History (2)

comment:1 by myob, 9 years ago

I've just found this is a dupe, searched for "multisession" not "multi session". #3473 is the original ticket.

Could someone close this?

comment:2 by anevilyak, 9 years ago

Blocked By: 3473 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.