Opened 13 years ago

Closed 11 years ago

#711 closed bug (duplicate)

[app_server] extremely high cpu usage on replicant movement

Reported by: diver Owned by: stippi
Priority: low Milestone: R1
Component: Servers/app_server Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

For example launch Pulse and Clock and move it's replicant around screen, you will see 100% cpu usage.

Change History (7)

comment:1 Changed 13 years ago by diver

Summary: [app_server] extremly high cpu usage on replicant movement[app_server] extremely high cpu usage on replicant movement

comment:2 Changed 13 years ago by jackburton

On which machine ? I can't reproduce this not even under vmware. I get 20/30% cpu load max when I move around replicants.

comment:3 Changed 13 years ago by diver

It's a P4 2.8 with 256 ram under vmware. I get now 30% cpu load too, seems this was improved alot. But now i started DeskCalc enlarged it twice and get 90/100% cpu load.

comment:4 Changed 13 years ago by axeld

Component: GeneralUser Interface/app_server
Description: modified (diff)
Owner: changed from axeld to stippi
Platform: All
Priority: normallow

comment:5 Changed 11 years ago by stippi

Status: newassigned

The problem is that app_server does not implement "rect tracking". It always uses transparent bitmaps to attach anything to the mouse cursor, so this is where the high CPU usage is coming from. This bug will be resolved when rect tracking is implemented.

comment:6 Changed 11 years ago by diver

Stippi, could this be a dup of bug #1837?

comment:7 Changed 11 years ago by stippi

Resolution: duplicate
Status: assignedclosed

Yes, indeed. Thanks.

Note: See TracTickets for help on using tickets.