Opened 9 years ago

Closed 8 years ago

#7159 closed bug (invalid)

Asus A7N8X-X: USB printer connection locks up Haiku

Reported by: Luposian Owned by: laplace
Priority: normal Milestone: R1
Component: Printing Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Not sure what to make of this. If I have my Brother HL-2040 unplugged, Haiku runs fine. As soon as I plug it in, Haiku freezes up solid. No mouse movement, nothing.

I have tried plugging it into each of all four USB ports on the back on the motherboard. Just once, Haiku booted with the printer connected/powered on, but took forever to finish booting up. Then, as soon as I went to the Printer pref, Haiku instantly froze up solid.

Not sure how to diagnose this issue, because unless the printer is connected, how would Haiku show any kind of error/problem in it's syslog? Yet, as soon as I plug it in, Haiku freezes up, so any data pertaining to that problem can't make it to the syslog or be saved.

Unless the issue is all to do with how Haiku sets things up initially. Could the BIOS have something to do with it, as well?

Change History (10)

comment:1 by stargatefan, 9 years ago

what version are you on ? should be in the about system box.

comment:2 by laplace, 9 years ago

  1. There is a USB printer device that you could remove. It is not used anyway. It is in directory /system/add-ons/kernel/drivers/dev/printer. You can safely remove that directory, reboot and then test what happens when you connect the printer.
  2. There is the USB transport add-on. It is required for printing over USB. If 1. didn't fix the problem, you can remove that too. The file is "/system/add-ons/Print/transport/USB Port".

in reply to:  description comment:3 by bonefish, 9 years ago

Replying to Luposian:

Not sure how to diagnose this issue, because unless the printer is connected, how would Haiku show any kind of error/problem in it's syslog? Yet, as soon as I plug it in, Haiku freezes up, so any data pertaining to that problem can't make it to the syslog or be saved.

See http://dev.haiku-os.org/wiki/ReportingBugs#Syslog.

in reply to:  1 comment:4 by Luposian, 9 years ago

Replying to stargatefan:

what version are you on ? should be in the about system box.

Haiku R40271

in reply to:  2 ; comment:5 by Luposian, 9 years ago

Replying to laplace:

  1. There is a USB printer device that you could remove. It is not used anyway. It is in directory /system/add-ons/kernel/drivers/dev/printer. You can safely remove that directory, reboot and then test what happens when you connect the printer.

Would like to do that, but Haiku is not at a level where I feel comfortable using it exclusively on my computer, so I am only using it in Live CD mode. It's not installed on my computer. Now, if there were a way I could build Haiku from within Haiku (GCC4 only; I'm a purist), then it becomes a lot more likely.

  1. There is the USB transport add-on. It is required for printing over USB. If 1. didn't fix the problem, you can remove that too. The file is "/system/add-ons/Print/transport/USB Port".

Same situation. I'm using Live CD, not an installed copy of Haiku on my system. Can't change anything.

in reply to:  5 comment:6 by anevilyak, 9 years ago

Replying to Luposian:

Would like to do that, but Haiku is not at a level where I feel comfortable using it exclusively on my computer, so I am only using it in Live CD mode. It's not installed on my computer. Now, if there were a way I could build Haiku from within Haiku (GCC4 only; I'm a purist), then it becomes a lot more likely.

That's been possible for well over a year.

in reply to:  5 ; comment:7 by laplace, 9 years ago

Replying to Luposian:

Replying to laplace:

  1. There is a USB printer device that you could remove. It is not used anyway. It is in directory /system/add-ons/kernel/drivers/dev/printer. You can safely remove that directory, reboot and then test what happens when you connect the printer.

Would like to do that, but Haiku is not at a level where I feel comfortable using it exclusively on my computer, so I am only using it in Live CD mode. It's not installed on my computer. Now, if there were a way I could build Haiku from within Haiku (GCC4 only; I'm a purist), then it becomes a lot more likely.

  1. There is the USB transport add-on. It is required for printing over USB. If 1. didn't fix the problem, you can remove that too. The file is "/system/add-ons/Print/transport/USB Port".

Same situation. I'm using Live CD, not an installed copy of Haiku on my system. Can't change anything.

Just tested with a Live CD. The reboot is not required. You can delete the driver & add-on from the running Live CD.

in reply to:  7 comment:8 by laplace, 9 years ago

Replying to laplace:

Just tested with a Live CD. The reboot is not required. You can delete the driver & add-on from the running Live CD.

After a reboot the files will be there again of course! It is amazing that it works so great!

comment:9 by Luposian, 8 years ago

I no longer own this system, so unless someone else wants this ticket to remain open (if they have similar (or the same) hardware and having the same issue), you can close it, as I no longer have any personal investment in having this issue resolved anymore.

comment:10 by korli, 8 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.