Opened 9 years ago

Closed 7 years ago

#7171 closed bug (invalid)

WebPositive doesn't free memory after closing the tab.

Reported by: mr.Noisy Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: memory leak Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hello! This is hrev40200 GCC4/Hybrid, WebPositive hrev573.

How to reproduce:

  1. Open http://shpilenok.livejournal.com/ and some pages linked from there.
  2. Check used the memory in ProcessCotroller. It was about 415 Mb in my case.
  3. Close all tabs, except one blank.
  4. Check used memory again. Values does not changed.

For me value of used memory with few open tabs reached 1400 Mb (!)

Attachments (1)

memory_usage.png (126.3 KB ) - added by mr.Noisy 9 years ago.

Download all attachments as: .zip

Change History (3)

by mr.Noisy, 9 years ago

Attachment: memory_usage.png added

comment:1 by deejam, 8 years ago

I've noticed that WebPositive uses more and more memory when left unused. I had one tab open (Facebook) over night and WebPositive went from 30,6MB usage to 96MB.

I've also noticed that when closing a tab, memory usage increase.

comment:2 by aldeck, 7 years ago

Resolution: invalid
Status: newclosed

Well it's entirely possible that there are memory leaks in WebPositive / WebKit, but the way you're testing things isn't correct. The memory is used for caching so that the next time you reload the page it's way faster. You actually want the gigabytes of ram you bought with your computer to be used for something :)

For example, if you close a tab and reopen the same url again in a new tab you'll see that the memory usage doesn't increase, because it reuses the cached data in memory.

As for the facebook test, as the page updates itself, it probably cached more data overnight and it again doesn't prove that there is a problem.

I've tested in the old Web+ also and it looks ok. It's also possible that the recent Webkit update fixed some leaks. In any case, i'm going to close this ticket as invalid, but anyone feel free to create a new ticket with a better testcase.

Note: See TracTickets for help on using tickets.