Opened 9 years ago

Closed 7 years ago

#7202 closed bug (invalid)

Emptying trash took 27 minutes

Reported by: Karvjorm Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems Version: R1/Development
Keywords: Trash emptying very slow Cc: Karvjorm
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I consider this bug though emptying trash succeeded. But it took very long time to process all files.

(History:) I tried to checkout webpositive webkit from the svn trunk to my SenryuPE disk. But there wasn't enough room for it. So I decided to delete those files. From SenryuPE to Trash it took only 2 seconds or less. But when I tried to empty trash, it took about 27 minutes.

As you can see in Terminal window printouts, Tracker mode window has a Finnish title "Seuraajatila". And "Desktop" is "Työpöytä" in Finnish. BTW, there is obviously also an aligment bug with Id columns. I'm running Haiku hrev40352.

Attachments (5)

already-8-minutes.png (59.5 KB ) - added by Karvjorm 9 years ago.
Emptying trash after 8 minutes
already-11-minutes.png (60.6 KB ) - added by Karvjorm 9 years ago.
Emptying trash after 11 minutes
already-25-minutes.png (61.7 KB ) - added by Karvjorm 9 years ago.
Emptying trash after 25 minutes
already-25-minutes.2.png (61.7 KB ) - added by Karvjorm 9 years ago.
Emptying trash after 27 minutes
after-27-minutes.png (57.8 KB ) - added by Karvjorm 9 years ago.
When emptying is completed after 27 minutes

Download all attachments as: .zip

Change History (10)

by Karvjorm, 9 years ago

Attachment: already-8-minutes.png added

Emptying trash after 8 minutes

by Karvjorm, 9 years ago

Attachment: already-11-minutes.png added

Emptying trash after 11 minutes

by Karvjorm, 9 years ago

Attachment: already-25-minutes.png added

Emptying trash after 25 minutes

by Karvjorm, 9 years ago

Attachment: already-25-minutes.2.png added

Emptying trash after 27 minutes

by Karvjorm, 9 years ago

Attachment: after-27-minutes.png added

When emptying is completed after 27 minutes

comment:1 by bonefish, 9 years ago

Owner: changed from nobody to axeld
Status: newassigned
Version: R1/alpha2R1/Development

Probably related: I also noticed that copying/unzipping something (probably preferably lots of small files) on an almost full volume (like a default-sized alpha image) is very disk intensive. Experienced in qemu with 512 MB RAM, without swap file. Smells block cache or BFS related.

comment:2 by Karvjorm, 9 years ago

It is possible that this SenryuPE disk is heavily fragmented. But 27 minutes is still too much, I think.

in reply to:  2 comment:3 by anevilyak, 9 years ago

Replying to Karvjorm:

It is possible that this SenryuPE disk is heavily fragmented. But 27 minutes is still too much, I think.

To some extent, deleting files on BFS will always be slower than on most other filesystems since deleting a file also entails removing all its attributes (which owing to the way BFS is structured is more or less equivalent to traversing an additional directory for every file that has attrs) and removing it from any indices that it's referenced in, but it shouldn't quite be *this* bad.

comment:4 by paulogeyer, 7 years ago

just tried to empty my trash here, (more than 23000 files), it took just a few seconds, I think this issue can be closed now

I'm using alpha 4

comment:5 by kallisti5, 7 years ago

Resolution: invalid
Status: assignedclosed

Closing for now as invalid. I've never heard of this problem before so I'm assuming it was a one-off issue. (maybe related to SenryuPE)

Feel free to request to be re-opened if it can be reproduced on H1A4 or later.

Note: See TracTickets for help on using tickets.